Bug 1303077 - hammer package list doesn't lists all installed packages for a specified host
hammer package list doesn't lists all installed packages for a specified host
Status: CLOSED DUPLICATE of bug 1420503
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 08:30 EST by Sachin Ghai
Modified: 2017-09-25 10:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-25 02:03:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13464 None None None 2016-04-22 12:59 EDT

  None (edit)
Description Sachin Ghai 2016-01-29 08:30:16 EST
Description of problem: 
hammer package list doesn't lists all packages for a specified host

# hammer -u admin -p changeme host package list --host-id 5

----------------------------------------
NVRA                                    
----------------------------------------
acl-2.2.51-12.el7.x86_64                
adwaita-cursor-theme-3.14.1-1.el7.noarch
adwaita-icon-theme-3.14.1-1.el7.noarch  
aic94xx-firmware-30-6.el7.noarch        
alsa-firmware-1.0.28-2.el7.noarch       
alsa-lib-1.0.28-2.el7.x86_64            
alsa-tools-firmware-1.0.28-2.el7.x86_64 
apr-1.4.8-3.el7.x86_64                  
apr-util-1.5.2-6.el7.x86_64             
at-3.1.13-20.el7.x86_64                 
atk-2.14.0-1.el7.x86_64                 
at-spi2-atk-2.8.1-4.el7.x86_64          
at-spi2-core-2.8.0-6.el7.x86_64         
audit-2.4.1-5.el7.x86_64                
audit-libs-2.4.1-5.el7.x86_64           
augeas-libs-1.4.0-2.el7.x86_64          
autoconf-2.69-11.el7.noarch             
autogen-libopts-5.18-5.el7.x86_64       
automake-1.13.4-3.el7.noarch            
avahi-autoipd-0.6.31-15.el7.x86_64      
----------------------------------------
[root@cloud-qe-4 ~]# hammer -u admin -p changeme host package list --help

Usage:
    hammer host package list [OPTIONS]

Options:
 --host HOST_NAME              Name to search by
 --host-id HOST_ID              
 -h, --help                    print help


Version-Release number of selected component (if applicable):

katello-2.5.0-3.nightly.el7.noarch
foreman-release-1.11.0-0.develop.201601211808gitd546fd0.el7.noarch
tfm-rubygem-hammer_cli_katello-0.0.20-1.el7.noarch
tfm-rubygem-hammer_cli-0.5.1-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.  hammer -u admin -p changeme host package list --help
2.
3.

Actual results:
hammer package list doesn't lists all installed packages for a specified host

Expected results:
should list all packages and we should add option to list #no of packages per page

Additional info:
Comment 1 Sachin Ghai 2016-01-29 08:31:22 EST
Created redmine issue http://projects.theforeman.org/issues/13464 from this bug
Comment 3 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Bryan Kearney 2016-07-26 11:36:40 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 6 Bryan Kearney 2016-08-10 12:12:25 EDT
Upstream bug component is Content Management
Comment 7 Bryan Kearney 2016-08-10 15:13:15 EDT
Upstream bug component is Hammer - Content
Comment 8 Bryan Kearney 2016-08-10 16:14:13 EDT
Upstream bug component is Content Management
Comment 9 Bryan Kearney 2016-08-10 18:13:52 EDT
Upstream bug component is Hammer - Content
Comment 12 Sachin Ghai 2016-11-21 06:17:16 EST
Still reproducible with sat6.3

satellite-installer-6.3.0-3.el7sat.noarch


[root@qe-testing-rhel6 ~]#  hammer -u admin -p changeme host package list --host-id 2
--------------------------------------
NVRA                                  
--------------------------------------
acl-2.2.51-12.el7.x86_64              
aic94xx-firmware-30-6.el7.noarch      
alsa-firmware-1.0.28-2.el7.noarch     
alsa-lib-1.1.1-1.el7.x86_64           
alsa-tools-firmware-1.1.0-1.el7.x86_64
audit-2.6.5-3.el7.x86_64              
audit-libs-2.6.5-3.el7.x86_64         
augeas-libs-1.4.0-2.el7.x86_64        
authconfig-6.2.8-14.el7.x86_64        
autogen-libopts-5.18-5.el7.x86_64     
basesystem-10.0-7.el7.noarch          
bash-4.2.46-20.el7_2.x86_64           
bind-libs-lite-9.9.4-38.el7_3.x86_64  
bind-license-9.9.4-38.el7_3.noarch    
binutils-2.25.1-22.base.el7.x86_64    
biosdevname-0.7.2-1.el7.x86_64        
btrfs-progs-4.4.1-1.el7.x86_64        
bzip2-libs-1.0.6-13.el7.x86_64        
ca-certificates-2015.2.6-73.el7.noarch
chkconfig-1.7.2-1.el7.x86_64          
--------------------------------------
Page 1 of 19 (use --page and --per-page for navigation)
[root@qe-testing-rhel6 ~]#  hammer -u admin -p changeme host package list --help
Usage:
    hammer host package list [OPTIONS]

Options:
 --host HOST_NAME              Name to search by
 --host-id HOST_ID              
 -h, --help                    print help
Comment 14 Anand Agrawal 2017-04-25 02:03:35 EDT

*** This bug has been marked as a duplicate of bug 1420503 ***

Note You need to log in before you can comment on or make changes to this bug.