Bug 1303092 - GTK warnings when help/manage repositories are launched in GUI
GTK warnings when help/manage repositories are launched in GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: William Poteat
John Sefler
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 09:19 EST by Rehana
Modified: 2016-05-10 16:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:40:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2016-01-29 09:19:30 EST
Description of problem:


Version-Release number of selected component (if applicable):
subscription management rules: 5.19
subscription-manager: 1.16.8-1.el6
python-rhsm: 1.16.6-1.el6


How reproducible:
2/2

Steps to Reproduce:
1.Launch Help from subscription-manager gui
2.Launch system --> Repositories
3.

Actual results:

1 ) when help is launched
-------------------
(gnome-help:13781): Gtk-CRITICAL **: IA__gtk_tool_button_new: assertion `icon_widget == NULL || GTK_IS_MISC (icon_widget)' failed

(gnome-help:13781): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gnome-help:13781): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(gnome-help:13781): Gtk-CRITICAL **: IA__gtk_toolbar_insert: assertion `GTK_IS_TOOL_ITEM (item)' failed

(gnome-help:13781): Gtk-CRITICAL **: IA__gtk_tool_button_new: assertion `icon_widget == NULL || GTK_IS_MISC (icon_widget)' failed

(gnome-help:13781): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gnome-help:13781): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(gnome-help:13781): Gtk-CRITICAL **: IA__gtk_toolbar_insert: assertion `GTK_IS_TOOL_ITEM (item)' failed
OMF category 'GNOME|Accessories' not recognised, ignoring.
OMF category 'GNOME|Accessories' not recognised, ignoring.

2) when manager repos are launched
------------------

/usr/share/rhsm/subscription_manager/gui/reposgui.py:194: GtkWarning: IA__gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed
  self.main_content_container.remove(self.details_vbox)

Expected results:
no warnings

Additional info:
Comment 2 Adrian Likins 2016-02-10 12:32:10 EST
For 1) (the gnome-help warnings), it's gnome-help spewing to it's stderr, which is inherited from subscription-manager-gui. 

To shut it up, change managergui.py's gnome-open call to something like

DEVNULL = open(os.devnull, 'w')
subprocess.call(["gnome-open","ghelp:subscription-manager"],
                 stderr=DEVNULL)

Might not hurt to devnull stdout, but I didn't test.
Comment 3 Adrian Likins 2016-02-10 12:40:59 EST
For 2), the reposgui.py thing

Looks like src/subscription-manager/gui/data/glade/repositories.glade didn't get updated to use the new name for the main container.

repositories.ui (gtk3) has a 'main_content_container', while repositories.glade (gtk2/rhel6) has 'main_container'.

Change repositories.glade to use 'main_content_container'


The reposgui.py code seems to be removing the repo details widget at some point, which is likely fine, but I think it may be able to just hide() it.
Comment 6 Rehana 2016-02-24 04:11:45 EST
Retested with,

subscription management server: 0.9.51.15-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-3.el6
python-rhsm: 1.16.6-1.el6

No GTK warnings are displayed after launching "Help" and "Repositories" from subscription-manager GUI

Moving the bug to "Verified"
Comment 8 errata-xmlrpc 2016-05-10 16:40:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.