Bug 1303096 - MIQ retirement statemachine processed in the zone that its triggered in
MIQ retirement statemachine processed in the zone that its triggered in
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
All All
unspecified Severity high
: GA
: 5.5.3
Assigned To: Tina Fitzgerald
Alex Newman
: ZStream
Depends On: 1302107
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 09:31 EST by John Prause
Modified: 2016-04-13 14:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, when service retirement was executed in the CloudForms Management Engine Appliance from a zone without the Automate role enabled, the request was queued in the wrong zone. This prevented the virtual machine and service from being retired. Now, when retiring a service, the zone parameter is cleared if the Automate role is not enabled, and retirement executes in the correct zone regardless of Automate configuration.
Story Points: ---
Clone Of: 1302107
Environment:
Last Closed: 2016-04-13 14:42:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2016-02-29 13:16:07 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=802af01e8f01deaa99f60b53db371e019e6af0c0

commit 802af01e8f01deaa99f60b53db371e019e6af0c0
Merge: c3ba0a5 576a587
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Feb 29 13:12:19 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Feb 29 13:12:19 2016 -0500

    Merge branch 'cherry_pick_zone_fix' into '5.5.z'
    
    Clear zone if automate role not enabled.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1303096
    
    Original: https://bugzilla.redhat.com/show_bug.cgi?id=1302107
    PR: https://github.com/ManageIQ/manageiq/pull/6870
    
    Clean cherry-pick for miq_ae_engine.rb
    Conflicts on all spec tests.
    
    
    See merge request !818

 lib/miq_automation_engine/engine/miq_ae_engine.rb  |  2 +-
 .../miq_ae_state_machine_multi_spec.rb             |  4 +-
 .../miq_ae_state_machine_retry_spec.rb             |  4 +-
 .../miq_automation_engine/miq_ae_engine_spec.rb    | 43 +++++++++++++++++++---
 spec/models/resource_action_spec.rb                |  4 +-
 5 files changed, 48 insertions(+), 9 deletions(-)
Comment 4 errata-xmlrpc 2016-04-13 14:42:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.