Bug 1303113 - systemd rpm does not own /usr/lib/systemd/scripts/
systemd rpm does not own /usr/lib/systemd/scripts/
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 10:15 EST by Eric Paris
Modified: 2016-08-22 12:00 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 12:00:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2016-01-29 10:15:29 EST
I know that systemd would not by default create files in /usr/lib/systemd/scripts but right now my system has owned files in there, but the directory itself is not owned. It seems like systemd should list that dir in %files, but I understand if you didn't want to and said that each user should claim it in their files...

# rpm -qf /usr/lib/systemd/
systemd-222-13.fc23.x86_64

# rpm -qf /usr/lib/systemd/scripts/
file /usr/lib/systemd/scripts is not owned by any package

# rpm -qf /usr/lib/systemd/scripts/nfs-utils_env.sh 
nfs-utils-1.3.3-6.rc3.fc23.x86_64
Comment 1 Harald Hoyer 2016-01-29 10:24:13 EST
I would blame nfs-utils for it.. it's not a documented, supported directory, IIRC.
Comment 2 Eric Paris 2016-01-29 10:26:38 EST
kicking to nfs-utils, so they claim it...
Comment 3 Steve Dickson 2016-01-29 11:23:28 EST
(In reply to Harald Hoyer from comment #1)
> I would blame nfs-utils for it.. it's not a documented, supported directory,
> IIRC.

I guess nfs-utils does create the directory 

mkdir -p $RPM_BUILD_ROOT/usr/lib/systemd/scripts

So I guess nfs-utils needs at

%dir /usr/lib/systemd/script under the %files

Anybody know what the macro is for usr/lib/systemd?
Comment 4 Zbigniew Jędrzejewski-Szmek 2016-01-29 14:22:00 EST
Why would nfs-utils put scripts in systemd package's directory? They should go into /usr/libexec/nfs-utils or %{_libdir}/nfs-utils/.
Comment 5 Steve Dickson 2016-01-30 18:24:19 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #4)
> Why would nfs-utils put scripts in systemd package's directory? They should
> go into /usr/libexec/nfs-utils or %{_libdir}/nfs-utils/.

It's simply the way upstream did it... I guess we
can make the change... Just out of curiously why 
is  %{_libdir}/nfs-utils/ a better place?
Comment 6 Zbigniew Jędrzejewski-Szmek 2016-01-30 18:55:29 EST
/usr/lib/systemd/ belongs to systemd, so other packages should not put stuff there, unless it's documented to do so. Using /usr/lib/systemd/systemd is fine, but /usr/lib/systemd/scripts is not. In principle systemd could start using that directory for some internal purpose, e.g. for scripts to be executed during boot (or whatever). In practice it's unlikely to be a problem, but even then it's confusing, because it's unclear who is responsible for that directory.

It's not terribly important, it's probably not even worth patching it in Fedora. It would be better to change it upstream and let the change trickle down to Fedora.

Note You need to log in before you can comment on or make changes to this bug.