Bug 1303116 - Remove Multicast Definitions from jasper Reports deployment
Summary: Remove Multicast Definitions from jasper Reports deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: jasperreports-server-pro
Version: 3.6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-3.6.3
: 3.6.3
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks: RHEV_36_HTB
TreeView+ depends on / blocked
 
Reported: 2016-01-29 15:27 UTC by Martin Tessun
Modified: 2016-05-23 11:03 UTC (History)
14 users (show)

Fixed In Version: jasperreports-server-pro-6.0.1-5.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:53:59 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0409 normal SHIPPED_LIVE jasperreports-server-pro bug fix and enhancement update 2016-03-10 00:04:07 UTC

Description Martin Tessun 2016-01-29 15:27:36 UTC
Description of problem:
Installation of reporting does fail during setup of Jasper in case multicast is disabled on the system.

Version-Release number of selected component (if applicable):
RHEV 3.6 beta3

How reproducible:
Always

Steps to Reproduce:
1. Disable multicasting completely on the RHEV-M
2. install Reports and DWH
3. Run engine-setup and enable DWH and Reports

Actual results:
Setup will fail while setting up Jasper Reports

Expected results:
Setup should succeed.


Additional info:

Error during deploy:

     [java] Resource name: applicationContext-virtual-data-source.xml
     [java] Error starting heartbeat. Error was: No such device
     [java] java.net.SocketException: No such device
     [java]     at java.net.PlainDatagramSocketImpl.join(Native Method)
     [java]     at java.net.AbstractPlainDatagramSocketImpl.join(AbstractPlainDatagramSocketImpl.java:179)
     [java]     at java.net.MulticastSocket.joinGroup(MulticastSocket.java:319)
     [java]     at net.sf.ehcache.distribution.MulticastKeepaliveHeartbeatReceiver.init(MulticastKeepaliveHeartbeatReceiver.java:88)
     [java]     at net.sf.ehcache.distribution.MulticastRMICacheManagerPeerProvider.init(MulticastRMICacheManagerPeerProvider.java:95)
     [java]     at net.sf.ehcache.CacheManager.doInit(CacheManager.java:439)
     [java]     at net.sf.ehcache.CacheManager.init(CacheManager.java:374)
     [java]     at net.sf.ehcache.CacheManager.<init>(CacheManager.java:259)
     [java]     at net.sf.ehcache.CacheManager.newInstance(CacheManager.java:1029)
     [java]     at net.sf.ehcache.CacheManager.newInstance(CacheManager.java:1005)
     [java]     at net.sf.ehcache.CacheManager.create(CacheManager.java:990)
     [java]     at net.sf.ehcache.hibernate.SingletonEhCacheRegionFactory.start(SingletonEhCacheRegionFactory.java:77)
     [java]     at org.hibernate.impl.SessionFactoryImpl.<init>(SessionFactoryImpl.java:221)
     [java]     at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1341)
     [java]     at org.springframework.orm.hibernate3.LocalSessionFactoryBean.newSessionFactory(LocalSessionFactoryBean.java:863)
     [java]     at org.springframework.orm.hibernate3.LocalSessionFactoryBean.buildSessionFactory(LocalSessionFactoryBean.java:782)
     [java]     at org.springframework.orm.hibernate3.AbstractSessionFactoryBean.afterPropertiesSet(AbstractSessionFactoryBean.java:188)
     [java]     at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1571)
     [java]     at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1509)
     [java]     at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:521)
     [java]     at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:458)
     [java]     at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:296)

After removing *all* multicast configs from jasper-pro, e.g. from /usr/share/jasperreports-server-pro/buildomatic/conf_source/iePro/classes/ehcache_hibernate.xml:

---8<---
<cacheManagerPeerProviderFactory
class="net.sf.ehcache.distribution.RMICacheManagerPeerProviderFactory"

properties="peerDiscovery=automatic,multicastGroupAddress=228.0.0.1,multicastGroupPort=4446,timeToLive=1"/>
--->8---

deployment succeeds:

Comment 5 Yaniv Kaul 2016-02-15 14:15:50 UTC
Pavel - does that happen on 3.5.8 as well?

Comment 6 Lukas Svaty 2016-02-16 09:53:30 UTC
Did reproduce in the past on 3.6.3

Now tested on 3.5.8 with these packages and it did  NOT reproduce:

OS: rhevm-appliance-20160214.0-1.x86_64.rhevm.ova

build:
vt20.2

Comment 7 Sandro Bonazzola 2016-02-16 14:16:59 UTC
Shirly, can you add reference to the patch causing this bug moving from NEW to POST?

Comment 8 Shirly Radco 2016-02-16 21:47:54 UTC
As this is a dist-git patch for the jasperreports-server-pro package, the patch is not in gerrit.

Comment 9 Lukas Svaty 2016-02-22 12:11:29 UTC
verified in rhevm-reports-3.6.3-1.el6ev.noarch

Comment 11 errata-xmlrpc 2016-03-09 19:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0409.html


Note You need to log in before you can comment on or make changes to this bug.