Bug 1303122 - Azure api version issue - The resource type 'locations/vmSizes' could not be found in the namespace
Azure api version issue - The resource type 'locations/vmSizes' could not be...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
All All
high Severity urgent
: GA
: 5.5.3
Assigned To: Bronagh Sorota
Jeff Teehan
provider:azure
: ZStream
Depends On: 1302786
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 10:47 EST by Greg Blomquist
Modified: 2016-04-13 14:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, there was an issue with the Azure API version in that the resource type 'locations/vmSizes' could not be found in the namespace. This was caused due to the outdated azure-armrest gem. This fix updates azure-armrest gem to 0.1.0 -- removed outdated comment regarding color gem. This has now resolved the issue.
Story Points: ---
Clone Of: 1302786
Environment:
Last Closed: 2016-04-13 14:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 18:38:44 EDT

  None (edit)
Comment 1 Bronagh Sorota 2016-02-01 12:50:49 EST
create an MR for this fix:
http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/cfme/merge_requests/760
Comment 3 CFME Bot 2016-02-22 15:28:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d867c61861a335a4d247749e02af054fb8cdedc3

commit d867c61861a335a4d247749e02af054fb8cdedc3
Merge: 5a1f27f 4a96259
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Feb 22 15:24:06 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Feb 22 15:24:06 2016 -0500

    Merge branch '5.5.z-updatedarmrestgem' into '5.5.z'
    
    Update azure-armrest gem to 0.1.0, removed outdated comment regarding color gem.
    
    
    Update azure-armrest gem to 0.1.0, removed outdated comment regarding color gem.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1303122
    
    clean cherrypick.
    
    upstream PR: https://github.com/ManageIQ/azure-armrest/pull/120
    
    See merge request !760

 Gemfile | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
Comment 7 Jeff Teehan 2016-03-22 14:24:13 EDT
This is verified fix on multiple accounts with 5.5.3.2

Default Credentials	Valid
Last Refresh	
Success - 7 Minutes Ago

Works out of the box.
Comment 9 errata-xmlrpc 2016-04-13 14:42:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.