Bug 1303122 - Azure api version issue - The resource type 'locations/vmSizes' could not be found in the namespace
Azure api version issue - The resource type 'locations/vmSizes' could not be...
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
All All
high Severity urgent
: GA
: 5.5.3
Assigned To: Bronagh Sorota
Jeff Teehan
: ZStream
Depends On: 1302786
  Show dependency treegraph
Reported: 2016-01-29 10:47 EST by Greg Blomquist
Modified: 2016-04-13 14:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, there was an issue with the Azure API version in that the resource type 'locations/vmSizes' could not be found in the namespace. This was caused due to the outdated azure-armrest gem. This fix updates azure-armrest gem to 0.1.0 -- removed outdated comment regarding color gem. This has now resolved the issue.
Story Points: ---
Clone Of: 1302786
Last Closed: 2016-04-13 14:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Comment 1 Bronagh Sorota 2016-02-01 12:50:49 EST
create an MR for this fix:
Comment 3 CFME Bot 2016-02-22 15:28:24 EST
New commit detected on cfme/5.5.z:

commit d867c61861a335a4d247749e02af054fb8cdedc3
Merge: 5a1f27f 4a96259
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Feb 22 15:24:06 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Feb 22 15:24:06 2016 -0500

    Merge branch '5.5.z-updatedarmrestgem' into '5.5.z'
    Update azure-armrest gem to 0.1.0, removed outdated comment regarding color gem.
    Update azure-armrest gem to 0.1.0, removed outdated comment regarding color gem.
    clean cherrypick.
    upstream PR: https://github.com/ManageIQ/azure-armrest/pull/120
    See merge request !760

 Gemfile | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
Comment 7 Jeff Teehan 2016-03-22 14:24:13 EDT
This is verified fix on multiple accounts with

Default Credentials	Valid
Last Refresh	
Success - 7 Minutes Ago

Works out of the box.
Comment 9 errata-xmlrpc 2016-04-13 14:42:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.