Bug 1303123 - docker requires an updated selinux-policy-targeted for interfaces it uses to be mainstream
docker requires an updated selinux-policy-targeted for interfaces it uses to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On: 1297815
Blocks: 1341257
  Show dependency treegraph
 
Reported: 2016-01-29 10:51 EST by Daniel Walsh
Modified: 2016-11-04 05:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1341257 (view as bug list)
Environment:
Last Closed: 2016-11-04 05:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the difference on docker* files between Fedora and RHEL (7.76 KB, patch)
2016-05-31 08:08 EDT, Daniel Walsh
no flags Details | Diff

  None (edit)
Description Daniel Walsh 2016-01-29 10:51:19 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Lukas Vrabec 2016-05-31 07:51:01 EDT
Hi Dan, 
Do you have some more info related to this BZ? 
I installed actual docker (and docker-selinux) package from brew and it looks fine.
Could you point me where can I found missing interfaces? 

Thank you.
Comment 3 Daniel Walsh 2016-05-31 08:08 EDT
Created attachment 1163202 [details]
Here is the difference on docker* files between Fedora and RHEL

We have not removed the cruft that we added to the RHEL7 docker-selinux package, which is allowing this to install.
Comment 4 Lukas Vrabec 2016-05-31 09:36:22 EDT
OK, I need to backport fedora docker policy to selinux-policy package and update interfaces. These changes will be in rhel distro-selinux package and during docker-selinux installation process will be docker distro-policy replaced by policy shipped by docker-selinux package.
Comment 5 Lukas Vrabec 2016-06-07 06:05:53 EDT
Lokesh, 
I sent you patch for docker.spec file and built selinux-policy package with changes related to docker:
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=498234

Could you create builds with my patch included and test it? 

Thank you!
Comment 7 Lukas Vrabec 2016-06-20 08:22:58 EDT
Added patch for docker to make it working on rhel-7.3. 
Moving assigne to Dan.
Comment 8 Daniel Walsh 2016-06-20 14:49:44 EDT
Lokesh, we will need this patch when we are releasing docker for 7.3, we should be able to build off of the master branch at that time.  Since we will be having one or more releases before 7.3 we need to hold off on this.
Comment 9 Lokesh Mandvekar 2016-06-20 14:51:56 EDT
yup, on hold until extras 7.3
Comment 10 Daniel Walsh 2016-08-19 08:31:37 EDT
We have the branch available I believe, moving to modified.
Comment 13 errata-xmlrpc 2016-11-04 05:09:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2016-2634.html

Note You need to log in before you can comment on or make changes to this bug.