Bug 1303126 - Upgrade of selinux-policy-targeted emits warnings
Summary: Upgrade of selinux-policy-targeted emits warnings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 1393066
TreeView+ depends on / blocked
 
Reported: 2016-01-29 15:53 UTC by Pete Houston
Modified: 2017-08-01 15:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:10:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Pete Houston 2016-01-29 15:53:06 UTC
Description of problem: An upgrade of selinux-policy-targeted via yum warned about 2 missing .pp files which it tried to remove. This is almost certainly benign, but worth at least recording here.


Version-Release number of selected component (if applicable):
Upgrading from 3.12.1-153.el7_0.13 to 3.13.1-60.el7


How reproducible: unknown - it has upgraded now.


Steps to Reproduce:
1. Have a running CentOS 7.0 system with selinux-policy and selinux-policy-targeted 3.12.1-153.el7_0.13 installed.
2. sudo yum update selinux-policy selinux-policy-targeted
3. Receive the warnings as selinux-policy-targeted upgrades in the cleanup phase


Actual results:

  Cleanup    : selinux-policy-targeted-3.12.1-153.el7_0.13.noarch           3/4 
warning: file /etc/selinux/targeted/modules/active/modules/vbetool.pp: remove failed: No such file or directory
warning: file /etc/selinux/targeted/modules/active/modules/pkcsslotd.pp: remove failed: No such file or directory
  Cleanup    : selinux-policy-3.12.1-153.el7_0.13.noarch                    4/4 

Expected results:

  Cleanup    : selinux-policy-targeted-3.12.1-153.el7_0.13.noarch           3/4 
  Cleanup    : selinux-policy-3.12.1-153.el7_0.13.noarch                    4/4 

Additional info:

Comment 5 errata-xmlrpc 2017-08-01 15:10:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.