Bug 1303230 - The docs aren't being built in rawhide
The docs aren't being built in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vagrant-hostmanager (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
:
Depends On: 1303239
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 16:42 EST by Randy Barlow
Modified: 2016-02-07 12:47 EST (History)
1 user (show)

See Also:
Fixed In Version: vagrant-hostmanager-1.7.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 12:46:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-01-29 16:42:54 EST
There is an issue that I am unable to solve so far wherein the docs aren't getting built by gem install, even though the --document=ri,rdoc flag is being passed. In Fedora 23, this flag causes the docs to get built for this package but in Rawhide the docs do not get built and there is no error message.

Rawhide has rubygems-2.5.1-53 and F23 has rubygems-2.4.8-100, so perhaps that is relevant to determining why they work on F23 but not Rawhide. I am uncertain if this is a bug in Rawhide or not.

To work around this problem I've temporarily removed the docs from getting packaged so that I could release the 1.7.1 bugfix release:

http://pkgs.fedoraproject.org/cgit/rpms/vagrant-hostmanager.git/commit/?id=2a5dc4642413a517c04f06fced3bb4c721756dd0

This issue is to track that the docs aren't being built so that I remember to turn them back on once I am able to figure out how to do so.
Comment 1 Randy Barlow 2016-01-29 16:47:48 EST
For the record, on Rawhide the build looks like this:

$ gem install -V --local --install-dir ./usr/share/vagrant/gems --bindir ./usr/bin --force --ri --rdoc --backtrace vagrant-hostmanager-1.7.1.gem                                                   
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/.gitignore
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/CHANGELOG.md
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Gemfile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/LICENSE.txt
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/README.md
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Rakefile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_all.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_guest.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_host.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/command.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/config.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/errors.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/hosts_file/updater.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/plugin.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/provisioner.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/util.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/version.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/locales/en.yml
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/Vagrantfile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/test.sh
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/vagrant-hostmanager.gemspec
Successfully installed vagrant-hostmanager-1.7.1
1 gem installed


On F23, the build looks like this:

gem install -V --local --install-dir ./usr/share/vagrant/gems --bindir ./usr/bin --force --document=ri,rdoc --backtrace vagrant-hostmanager-1.7.1.gem
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/.gitignore
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/CHANGELOG.md
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Gemfile
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/LICENSE.txt
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/README.md
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Rakefile
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_all.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_guest.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_host.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/command.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/config.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/errors.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/hosts_file/updater.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/plugin.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/provisioner.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/util.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/version.rb
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/locales/en.yml
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/Vagrantfile
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/test.sh
/builddir/build/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/vagrant-hostmanager.gemspec
Successfully installed vagrant-hostmanager-1.7.1
Parsing documentation for vagrant-hostmanager-1.7.1
Parsing sources...
  7% [ 1/13]  lib/vagrant-hostmanager.rb
 15% [ 2/13]  lib/vagrant-hostmanager/action.rb
 23% [ 3/13]  lib/vagrant-hostmanager/action/update_all.rb
 30% [ 4/13]  lib/vagrant-hostmanager/action/update_guest.rb
 38% [ 5/13]  lib/vagrant-hostmanager/action/update_host.rb
 46% [ 6/13]  lib/vagrant-hostmanager/command.rb
 53% [ 7/13]  lib/vagrant-hostmanager/config.rb
 61% [ 8/13]  lib/vagrant-hostmanager/errors.rb
 69% [ 9/13]  lib/vagrant-hostmanager/hosts_file/updater.rb
 76% [10/13]  lib/vagrant-hostmanager/plugin.rb
 84% [11/13]  lib/vagrant-hostmanager/provisioner.rb
 92% [12/13]  lib/vagrant-hostmanager/util.rb
100% [13/13]  lib/vagrant-hostmanager/version.rb
Installing ri documentation for vagrant-hostmanager-1.7.1
Installing darkfish documentation for vagrant-hostmanager-1.7.1
Done installing documentation for vagrant-hostmanager after 0 seconds
1 gem installed
Comment 2 Randy Barlow 2016-01-29 16:50:35 EST
Whoops, the Rawhide one I cited didn't use --document, but this does and shows the same issue:

$ gem install -V --local --install-dir ./usr/share/vagrant/gems --bindir ./usr/bin --force --document=ri,rdoc --backtrace vagrant-hostmanager-1.7.1.gem
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/.gitignore
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/CHANGELOG.md
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Gemfile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/LICENSE.txt
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/README.md
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/Rakefile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_all.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_guest.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/action/update_host.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/command.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/config.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/errors.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/hosts_file/updater.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/plugin.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/provisioner.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/util.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/lib/vagrant-hostmanager/version.rb
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/locales/en.yml
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/Vagrantfile
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/test/test.sh
/home/rbarlow/rpmbuild/BUILD/vagrant-hostmanager-1.7.1/usr/share/vagrant/gems/gems/vagrant-hostmanager-1.7.1/vagrant-hostmanager.gemspec
Successfully installed vagrant-hostmanager-1.7.1
1 gem installed
Comment 4 Randy Barlow 2016-02-07 12:47:39 EST
Just realized I had accidentally set myself to the QA contact.

Note You need to log in before you can comment on or make changes to this bug.