Bug 1303261 - When using EQLX with triple, eqlx_pool= will always be null in /etc/cinder/cinder.conf
When using EQLX with triple, eqlx_pool= will always be null in /etc/cinder/ci...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ---
: 10.0 (Newton)
Assigned To: Jiri Stransky
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 20:21 EST by David Hill
Modified: 2017-07-27 06:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 04:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 277470 None None None 2016-02-22 08:06 EST
OpenStack gerrit 278990 None None None 2016-02-22 08:07 EST

  None (edit)
Description David Hill 2016-01-29 20:21:38 EST
Description of problem:
When using EQLX with triple, eqlx_pool= will always be null in /etc/cinder/cinder.conf because the template is using :

openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_lpool', undef),
openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller_pacemaker.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_lpool', undef),


instead of 
openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_pool', undef),
openstack-tripleo-heat-templates/puppet/manifests/overcloud_controller_pacemaker.pp:      eqlx_pool           => hiera('cinder::backend::eqlx::eqlx_pool', undef),





[root@overcloud-controller-0 hieradata]# cat cinder_eqlx_data.yaml

cinder::backend::eqlx::eqlx_chap_login:
cinder::backend::eqlx::eqlx_chap_password:
cinder::backend::eqlx::eqlx_group_name: my_group_name
cinder::backend::eqlx::eqlx_pool: default
cinder::backend::eqlx::eqlx_use_chap: false
cinder::backend::eqlx::san_ip: 10.0.0.0
cinder::backend::eqlx::san_login: username
cinder::backend::eqlx::san_password: password
cinder::backend::eqlx::san_thin_provision: true
cinder::backend::eqlx::volume_backend_name: tripleo_eqlx
cinder_enable_eqlx_backend: true




[root@overcloud-controller-0 cinder]# cat cinder.conf | grep eqlx_pool
#eqlx_pool=default
eqlx_pool=

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Include cinder-eqlx-config.yaml when deploying overcloud
2.
3.

Actual results:
eqlx_pool is empty


Expected results:
default value

Additional info:
Comment 2 Jiri Stransky 2016-02-22 08:06:55 EST
Fixed upstream by Rajini.
Comment 3 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Jiri Stransky 2016-10-05 04:37:11 EDT
The fixes have been merged some time ago and backported to stable/liberty. Please reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.