Bug 1303262 - Kernel suspend issues on 4.5-rc0 (regression)
Kernel suspend issues on 4.5-rc0 (regression)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 20:22 EST by davidgf
Modified: 2016-02-18 19:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 19:37:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg trace (19.84 KB, text/plain)
2016-02-07 12:32 EST, davidgf
no flags Details

  None (edit)
Description davidgf 2016-01-29 20:22:27 EST
Description of problem:

On a Dell XPS 13 laptop (9350) using the newest kernel 4.5-rc1 (named 4.5.0-0.rc1.git0.2) the laptop will come back immediately from suspend (close the lid, suspends and it comes back after 1 second).

This also creates some issues with bluetooth (can't connect anymore for some misterious reason, not relevant).

It works well using 4.5-rc0

Notes: I'm using Fedora 23 but rawhide kernel, cause my laptop is too new and unsupported on older kernels (at least without tweaks).
Comment 1 davidgf 2016-02-07 12:31:35 EST
I have more infornation!

Last kernel known to work well is: kernel-4.5.0-0.rc0.git1.2.fc24.x86_64
Next kernel that doesn't suspend the computer: kernel-4.5.0-0.rc0.git5.1.fc24.x86_64

I couldn't try any other releases in between since they failed according to koji (http://koji.fedoraproject.org/koji/packageinfo?packageID=8)

I have a dmesg trace, in this trace I send the computer to sleep after second 26 (more or less). Attached.
Comment 2 davidgf 2016-02-07 12:32 EST
Created attachment 1121943 [details]
Dmesg trace
Comment 3 davidgf 2016-02-18 19:37:03 EST
Ok I'm closing this.
After trying to bisect the kernel with little luck (I got inconsistent results with the same commit) and some other hardware madness going on I think it might be connected to the Dell firmware.

After upgrading to BIOS 1.2.3 seems that the problem has gone away. It suspends well with 4.5.0-rc4-git8 or so and it does it way faster than before (regardless of the kernel version) so I guess the Dell guys have fixed some of the bugs there.

Thanks!!!
David

Note You need to log in before you can comment on or make changes to this bug.