Bug 1303264 - [DOCS] Fix entitlement and user login issues in AEP Getting Started Guide
[DOCS] Fix entitlement and user login issues in AEP Getting Started Guide
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Zac Dover
Bob Kozdemba
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 20:57 EST by Vikram Goyal
Modified: 2016-02-23 21:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 21:56:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2016-01-29 20:57:10 EST
In the Getting Started Guide for AEP public beta [1]:

(via email from Bob Kozdemba):

"
- In the GS guide, Capt 2 step 2, the entitlement info looks like it was probably tested using an employee subscription. It looks like the RHEL sub is not included automatically if using with a customer sub, so the "--auto-attach" option won't work. Need to manually add the right subs

- In Step 3, the OSE 3.1 entitlement is not needed, so that reference can be removed (--enable="rhel-7-server-ose-3.1-rpms" \) - needs to be removed because the customer likely won't have the entitlement, which makes them think they can't proceed without it
"

Note added by Vikram: (The above issue is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1298370 and can be ignored).

Email continued:
"
- In Steps 6-8 - keep in mind a lot of customers won't have root access, especially if they are deploying via a cloud image on openstack. Recommended solution is to suggest a different user, such as "cloud_user"), and provide instructions using sudo (also need to mention how to configure sudo)
- Also in step 8, notice the internal RH URL in the config example "http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterpriseErrata/3.1/latest/RH7-RHAOS-3.1/x86_64/os/"

[1] https://access.redhat.com/documentation/en/red-hat-atomic-enterprise-platform/version-3.1/getting-started-guide/
Comment 3 Vikram Goyal 2016-02-23 21:56:23 EST
Thanks Zac and Bob. 

To confirm,

* A new cloud_user step has been added
* --auto-attach step has been removed
* rhel-7-server-ose-3.1-rpms entitlement has been removed.

This is now live here [1].

[1] https://access.redhat.com/documentation/en/red-hat-atomic-enterprise-platform/version-3.1/getting-started-guide/#aep_getting_started_procedure

Note You need to log in before you can comment on or make changes to this bug.