Bug 1303265 - On arm _gnu is no longer -gnuabi
On arm _gnu is no longer -gnuabi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-29 20:59 EST by Jakub Jelinek
Modified: 2016-02-04 18:22 EST (History)
11 users (show)

See Also:
Fixed In Version: rpm-4.13.0-0.rc1.11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 18:22:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelinek 2016-01-29 20:59:36 EST
The _gnu macro which should be predefined by rpm has changed during the last 24 hours or so on arm, previously it has been -gnuabi, now it is just -gnu.
https://kojipkgs.fedoraproject.org/packages/gcc/6.0.0/0.6.fc24/data/logs/armv7hl/build.log
still shows a successful build with -gnuabi, while
https://kojipkgs.fedoraproject.org//work/tasks/4041/12734041/build.log
from about 25 hours later already has -gnu, which of course breaks the build, on arm if the target triplet does not end with -gnueabi, it is considered to be the old ABI which is no longer supported.
For now I've worked around this bug by defining
%ifarch %{arm}
%global _gnu -gnueabi
%endif
myself, but this is going to break lots of things.
Is the _gnu macro predefined by rpm program/library, or comes from the rpm invocation (i.e. it might be also some rel-eng issue), or from macros, somewhere else?
Comment 1 Peter Robinson 2016-01-31 19:11:04 EST
this will block the mass rebuild.
Comment 2 Dan Horák 2016-02-01 08:50:58 EST
/usr/lib/rpm/platform/*/macros (part of rpm package) define _gnu
Comment 3 Jakub Jelinek 2016-02-01 08:55:12 EST
Those files have -gnu instead of -gnueabi even on F22, and from what I've tried, f23 (and f24 until very recently) worked fine in koji.  So it must be something different (overridden from rpm binary, or from mock/koji/whatever).
Comment 4 Nicolas Chauvet (kwizart) 2016-02-01 09:18:43 EST
I would add this bug as reference:
https://bugzilla.redhat.com/show_bug.cgi?id=1259833

Basically mock in the fedora infra is configured to use "mockhost=redhat-linux-gnu" everywhere. So no matters which arch it is, it's using -gnu suffix everywhere. armv7hl should stands for new ABI that alone from what I've understood.
Comment 5 Jakub Jelinek 2016-02-01 09:20:45 EST
Sadly, arm is an exception here, it really has to use gnueabi, otherwise config.guess/config.sub, lots of autotools etc. will get things wrong.
Comment 6 Ľuboš Kardoš 2016-02-01 09:30:33 EST
This was caused by a change in rpm. It will be fixed in rpm-4.13.0-0.rc1.21.fc24
Comment 7 Ľuboš Kardoš 2016-02-02 07:02:41 EST
In fc23 branch fixed in rpm-4.13.0-0.rc1.11.fc23.
Comment 8 Fedora Update System 2016-02-02 07:05:46 EST
rpm-4.13.0-0.rc1.11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-387992811b
Comment 9 Fedora Update System 2016-02-02 19:51:28 EST
rpm-4.13.0-0.rc1.11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-387992811b
Comment 10 Fedora Update System 2016-02-04 18:22:53 EST
rpm-4.13.0-0.rc1.11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.