Bug 130327 - mkinitrd-4.0.6-1 removes /lost+found directory when making initramfs
Summary: mkinitrd-4.0.6-1 removes /lost+found directory when making initramfs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-08-19 05:18 UTC by Constantin
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.1.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 15:04:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Constantin 2004-08-19 05:18:41 UTC
Description of problem:

Version-Release number of selected component (if applicable):
4.0.6-1

How reproducible:
mkinitrd /boot/initrd-2.6.8.1 2.6.8.1

Actual results:
due to undefined $MNTPOINT for initramfs it deletes lost+found on "/"
filesystem (mkinitrd script, line #556)

Additional info: e2fsck reports error about missing lost+found
may be cured by embracing line #556 
with: 
if [ -z "$initramfs" ]; then 
...
fi

Comment 1 Jeremy Katz 2004-08-19 15:04:23 UTC
Thanks, fixed in CVS (will be in 4.1.1)


Note You need to log in before you can comment on or make changes to this bug.