Bug 1303297 - panel
Summary: panel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: greenisland
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pier Luigi Fiorini
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-30 11:58 UTC by mastaiza
Modified: 2016-04-07 15:50 UTC (History)
3 users (show)

Fixed In Version: greenisland-0.7.90-0.2.20160227git.fc23 greenisland-0.7.90-0.2.20160227git.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-03 20:23:32 UTC


Attachments (Terms of Use)

Description mastaiza 2016-01-30 11:58:18 UTC
Description of problem:
no panels except the menu labels nothing more . is displayed in the menu not all applications . can't find the settings.
shell not very suitable for use.

Comment 1 Pier Luigi Fiorini 2016-01-30 12:02:14 UTC
Is it a VM or an actual PC?

Comment 2 mastaiza 2016-01-30 12:04:37 UTC
PC

Comment 3 Pier Luigi Fiorini 2016-01-30 12:11:30 UTC
Could you post the qtdiag output on pastebin please?
The command is qtdiag or the following if you run it from a tty with no X11:

qtdiag -platform greenisland

Comment 4 Pier Luigi Fiorini 2016-01-30 12:14:56 UTC
Upstream bug: https://github.com/hawaii-desktop/hawaii-shell/issues/204

Comment 5 Pier Luigi Fiorini 2016-02-07 08:28:05 UTC
This is a driver issue.

Some drivers report the wrong physical size (less than or equal to 0x0 mm) causing all sort of issues related to bad DPI calculation including:

- broken font rendering
- broken UI elements that are scaled according to DPIs such as the panel
- failure loading icon themes for SVG icons

This happens with all virtual machines including those created with virt-manager but can happen on bare metal, although I can't reproduce it with any of my computers.

Now upstream assumes a 100 DPI display when physical size is not valid.

The workaround works fine on virtual machine and is currently under more test.
Once merged upstream a new release will be done and Fedora packages will be updated.

Comment 6 Pier Luigi Fiorini 2016-02-23 21:00:04 UTC
Move the issue to greenisland because that's were the workaround is going to be.
The package is mock-building here, followed by a build for rawhide, 22 and 23 on Koji.

Comment 7 Fedora Update System 2016-03-02 06:38:03 UTC
hawaii-workspace-0.6.90-0.1.20160301git.fc22 hawaii-system-preferences-0.6.90-0.1.20160301git.fc22 hawaii-icon-theme-0.6.90-0.1.20160229git.fc22 libhawaii-0.6.90-0.1.20160222git.fc22 hawaii-widget-styles-0.6.90-0.1.20160229git.fc22 hawaii-shell-0.6.90-0.1.20160228git.fc22 greenisland-0.7.90-0.2.20160227git.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9407861569

Comment 8 Fedora Update System 2016-03-02 06:38:05 UTC
hawaii-workspace-0.6.90-0.1.20160301git.fc23 hawaii-system-preferences-0.6.90-0.1.20160301git.fc23 hawaii-icon-theme-0.6.90-0.1.20160229git.fc23 libhawaii-0.6.90-0.1.20160222git.fc23 hawaii-widget-styles-0.6.90-0.1.20160229git.fc23 hawaii-shell-0.6.90-0.1.20160228git.fc23 greenisland-0.7.90-0.2.20160227git.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4bd44c2ec2

Comment 9 Fedora Update System 2016-03-02 22:55:59 UTC
greenisland-0.7.90-0.2.20160227git.fc23, hawaii-icon-theme-0.6.90-0.1.20160229git.fc23, hawaii-shell-0.6.90-0.1.20160228git.fc23, hawaii-system-preferences-0.6.90-0.1.20160301git.fc23, hawaii-widget-styles-0.6.90-0.1.20160229git.fc23, hawaii-workspace-0.6.90-0.1.20160301git.fc23, libhawaii-0.6.90-0.1.20160222git.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4bd44c2ec2

Comment 10 Fedora Update System 2016-03-02 23:19:58 UTC
greenisland-0.7.90-0.2.20160227git.fc22, hawaii-icon-theme-0.6.90-0.1.20160229git.fc22, hawaii-shell-0.6.90-0.1.20160228git.fc22, hawaii-system-preferences-0.6.90-0.1.20160301git.fc22, hawaii-widget-styles-0.6.90-0.1.20160229git.fc22, hawaii-workspace-0.6.90-0.1.20160301git.fc22, libhawaii-0.6.90-0.1.20160222git.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9407861569

Comment 11 Fedora Update System 2016-03-03 20:23:19 UTC
greenisland-0.7.90-0.2.20160227git.fc23, hawaii-icon-theme-0.6.90-0.1.20160229git.fc23, hawaii-shell-0.6.90-0.1.20160228git.fc23, hawaii-system-preferences-0.6.90-0.1.20160301git.fc23, hawaii-widget-styles-0.6.90-0.1.20160229git.fc23, hawaii-workspace-0.6.90-0.1.20160301git.fc23, libhawaii-0.6.90-0.1.20160222git.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-04-07 15:49:58 UTC
greenisland-0.7.90-0.2.20160227git.fc22, hawaii-icon-theme-0.6.90-0.1.20160229git.fc22, hawaii-shell-0.6.90-0.1.20160228git.fc22, hawaii-system-preferences-0.6.90-0.1.20160301git.fc22, hawaii-widget-styles-0.6.90-0.1.20160229git.fc22, hawaii-workspace-0.6.90-0.1.20160301git.fc22, libhawaii-0.6.90-0.1.20160222git.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.