Bug 1303324 - Include big switch puppet manifests to RHOSP8
Include big switch puppet manifests to RHOSP8
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Hugh Brock
yeylon@redhat.com
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 14:40 EST by bigswitch
Modified: 2016-04-18 03:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:46:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2016-01-30 14:40:36 EST
Description of problem:

To integrate RHOSP8 and big switch SDN solution, we submitted few patches in puppet-neutron and tripleo-heat-templates upstream. These patched need to be included in RHOSP8.

The merged puppet-neutron patch for liberty is at
https://review.openstack.org/#/c/274122/

The tripleo-heat-templates patches under review are at
https://review.openstack.org/#/c/271922/
https://review.openstack.org/#/c/271940/
https://review.openstack.org/#/c/271953/
https://review.openstack.org/#/c/271990/

The patches for os-net-config will come out soon.
We will use this bugzilla to track the progress.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 bigswitch 2016-02-01 20:28:45 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/271940/ (master)
https://review.openstack.org/#/c/271953/ (liberty)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.gerrithub.io/#/c/261688/  (rpm-master)
Comment 5 bigswitch 2016-02-02 12:54:12 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/271940/ (master)
https://review.openstack.org/#/c/271953/ (liberty)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/274492/ (master)
Comment 6 bigswitch 2016-02-19 04:21:34 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/271940/ (master)
https://review.openstack.org/#/c/271953/ (liberty)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
Comment 7 bigswitch 2016-02-19 04:22:46 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/271940/ (master)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
Comment 8 bigswitch 2016-02-19 14:56:25 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
Comment 9 bigswitch 2016-02-19 16:12:19 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
https://review.openstack.org/#/c/282534/ (liberty)
Comment 10 bigswitch 2016-02-19 16:12:26 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/271922/ (master)
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
https://review.openstack.org/#/c/282534/ (liberty)
Comment 11 bigswitch 2016-02-23 11:15:42 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master)
https://review.openstack.org/#/c/271922/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
https://review.openstack.org/#/c/280496/ (liberty)
https://review.openstack.org/#/c/282534/ (liberty)
Comment 12 bigswitch 2016-02-24 18:01:08 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
https://review.openstack.org/#/c/280496/ (liberty)
Comment 13 bigswitch 2016-03-01 11:29:14 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
https://review.openstack.org/#/c/279842/ (master)
Comment 14 bigswitch 2016-03-02 17:15:52 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/279842/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
Comment 15 bigswitch 2016-03-02 17:16:00 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/279842/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
Comment 16 bigswitch 2016-03-07 22:09:36 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/279842/ (master)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
https://review.gerrithub.io/#/c/265470/ (master)
Comment 17 bigswitch 2016-03-08 11:25:30 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/279842/ (master)
https://review.gerrithub.io/#/c/265470/ (master, cherry-pick to liberty done)

Ongoing reviews:
https://review.openstack.org/#/c/274492/ (master)
Comment 18 bigswitch 2016-03-11 13:57:27 EST
A summary of latest progress

Merged reviews:
https://review.openstack.org/#/c/271963/ (master, cherry-pick to liberty done)
https://review.gerrithub.io/#/c/261688/  (rpm-master, cherry-pick to rpm-liberty done)
https://review.openstack.org/#/c/271990/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/271922/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/279842/ (master)
https://review.gerrithub.io/#/c/265470/ (master, cherry-pick to liberty done)
https://review.openstack.org/#/c/274492/ (master)
Comment 21 errata-xmlrpc 2016-04-07 17:46:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.