Bug 1303335 - Keyboard Switching (switch to the next layout) interface not working during Rawhide anaconda installs
Keyboard Switching (switch to the next layout) interface not working during R...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:8dc3fb0d022ad0372ba04f33105...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 20:29 EST by Noel McLoughlin
Modified: 2016-06-13 07:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303334
Environment:
Hypervisor process for VM: <posixuser> 3809 1 43 22:43 ? 00:13:16 qemu-system-x86_64 -enable-kvm -name f24rawhide -S -machine pc-i440fx-trusty,accel=kvm,usb=off -bios OVMF.fd -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid 559e3934-ff4e-b613-4d9d-5029d57ab943 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/f24rawhide.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot c -usb -drive file=/var/lib/libvirt/images/f24rawhide.img,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/home/enoemcl/workspace/ISO/Fedora-Live-Workstation-x86_64-rawhide-20160129.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=25,id=hostnet0,vhost=on,vhostfd=26 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:c8:f1:fe,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 127.0.0.1:1 -vga qxl -global qxl.ram_size=67108864 -global qxl.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,addr=0x4 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
Last Closed: 2016-03-09 14:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel McLoughlin 2016-01-30 20:29:24 EST
+++ This bug was initially created as a clone of Bug #1303334 +++

Description of problem:

ISSUE #1 

1. Launch Rawhide Live DVD installer
2. Choose Install to Disk
3. During Anaconda installation process click on [keyboard layout] button/toggle which is adjacent to [Help!] button on GUI console.
4. Note how this interface does not work.  User can only "change layout, i.e. Click to switch to the next layout" via LOCALIZATION -> Keyboard screen which is bit more work.  This interface is superfluous.

ISSUE #2

It was also noted the "switch keyboard layout by key combination" feature (i.e. CTRL+SPACEBAR, CTRL+CAPSLOCK, etc) does not work and selected configuration does not persist after interacting with the interface.


Version-Release number of selected component:
anaconda-core-24.9-1.fc24.x86_64
Comment 1 Jan Kurik 2016-02-24 09:22:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 David Shea 2016-03-09 14:07:54 EST
Whatever was causing this was probably something in libXklavier, but it seems to be working fine now.

Note You need to log in before you can comment on or make changes to this bug.