Bug 1303340 - GCompris 15.x must be run as root for audio
GCompris 15.x must be run as root for audio
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcompris (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-30 23:48 EST by Brian Dudek
Modified: 2016-04-21 21:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: gcompris-15.10-6.fc23 gcompris-15.10-6.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 15:21:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log file (611.11 KB, text/plain)
2016-01-31 16:57 EST, Brian Dudek
no flags Details

  None (edit)
Description Brian Dudek 2016-01-30 23:48:19 EST
Description of problem:

Audio only plays if gcompris is invoked as 'root'


Version-Release number of selected component (if applicable):
	
gcompris-15.10-2.fc23.x86_64

How reproducible:

100% reproducible

Steps to Reproduce:
1.  yum install gcompris
2.  as mortal user execute gcompris in a shell or with GNOME desktop icon audio will not play

3.  'su - root' in terminal then invoke gcompris, audio then works as expected.

Actual results:


Expected results:


Additional info:

Same results of no audio as mortal user with the prior version gcompris-15.02-2.fc23.x86_64

All other sound applications on the system work as expected.
Comment 1 Hans de Goede 2016-01-31 04:23:15 EST
Hi,

This works fine for me, likely something outside of gcompris is broken on your system. Is pulseaudio running as the user you've logged in?

How have you started the gnome session, just normally from gdm, or ... ?

Regards,

Hans
Comment 2 Brian Dudek 2016-01-31 16:57:04 EST
Nothing is broken on either build I've done in the last two days.  TuxPain has always had working audio.  I've been able to eventually get audio in gcompris to work on both systems but not on a clean build.

If I build out a clean Fedora 23 Workstation, then:
# yum -y install gcompris*

Audio will not work in gcompris, all other audio works on the system and in TuxPain

# yum -y update
Audio still does not work.

Invoking gcompris from the command line with the -s option does not work to overcome the issue.

On a clean build setting effects in the GUI will not stay enabled/checked once the app is closed.  Looking at gcompris.conf  fx  is properly set as fx=1 so it should work.  I have removed the /home/user/.config/gcompris directory between case scenarios with no luck.  Removing the gcompris_sql db file, correctly setting up the gcompris.conf file with fx=1, open the GUI, effects is then unchecked.  However, once audio starts to work after adding packages setting options in the GUI works as it should when opening and closing the GUI.

Attached is the dnf.log file sense the box was new.  Before the time 13:17 the audio was not working.  I add any RPM I though could be related.  I do not think the second set of packages fixed the issue because after audio started working I removed these packages and audio was still working.

In all cases pulseaudio is correctly running as the GDM logged in user.

I'm going to continue to work on this to identify the issue I'm having when building out a new system.  Do you see anything in the rpm log file that stands out?
Comment 3 Brian Dudek 2016-01-31 16:57 EST
Created attachment 1119929 [details]
dnf.log file
Comment 4 Hans de Goede 2016-02-01 08:54:50 EST
I think gcompris is using gstreamer for sound output, and the problem might be that gstreamer-plugins-base is missing (it gets added after 13:17 in the log).
Comment 5 Brian Dudek 2016-02-05 15:35:19 EST
Ah yes, thanks.  Without gstreamer-plugins-base the Effect configuration option will not stay clicked after the application closes.  Should this package be a dependency when a language package is added (ie gcompris-sound-en) because without the plugins audio will not work.
Comment 6 Hans de Goede 2016-02-23 06:58:40 EST
Thanks for testing, I've made gstreamer-plugins-base a dependency of gcompris, I've only done this for rawhide since most people will likely have gstreamer-plugins-base anyways and gcompris is quite large so I do not want to push an update when its not really necessary.
Comment 7 Laszlo Ersek 2016-04-10 05:59:30 EDT
Hi Hans,

I've encountered the same problem today, on Fedora 22. Google led me to this BZ.

Installing gstreamer-plugins-base manually worked for me as well, but I think it would be worthwhile to push an F22 update where gcompris depends on gstreamer-plugins-base explicitly. I had neither gcompris nor gstreamer-plugins-base installed, and the former didn't pull in the latter, confusing me.

What do you think? Should I clone this BZ for F22?

Thanks
Laszlo
Comment 8 Hans de Goede 2016-04-10 07:56:37 EDT
Hi,

(In reply to Laszlo Ersek from comment #7)
> Hi Hans,
> 
> I've encountered the same problem today, on Fedora 22. Google led me to this
> BZ.
> 
> Installing gstreamer-plugins-base manually worked for me as well, but I
> think it would be worthwhile to push an F22 update where gcompris depends on
> gstreamer-plugins-base explicitly. I had neither gcompris nor
> gstreamer-plugins-base installed, and the former didn't pull in the latter,
> confusing me.

gcompris is quite big(ish), 180MB for just the base package without any of the language-sounds addon, and people doing a standard workstation / livecd install will already have gstreamer-plugins-base I believe, so I really think this only impacts a few people vs pushing a big update to quite a few people ...

> What do you think? Should I clone this BZ for F22?

No need to clone it, if after the above explanation you still believe that this should be fixed for F22+, just reopen this bug.

Regards,

Hans
Comment 9 Laszlo Ersek 2016-04-11 03:16:01 EDT
The F22 system in question doesn't come from a direct (ISO-based) installation; it comes from F21 + fedup. I think that shouldn't be a very rare setup either.

Also, I think DRPM should be eliminate most of the payload? Given that only the spec file should change in this update.

I think I'll reopen this one. Thanks.
Comment 10 Fedora Update System 2016-04-11 07:10:03 EDT
gcompris-15.10-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-55558da0f8
Comment 11 Fedora Update System 2016-04-11 07:12:13 EDT
gcompris-15.10-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-855443a4b9
Comment 12 Laszlo Ersek 2016-04-11 07:24:46 EDT
Thank you. How can I install the F22 packages with yum? (I'd like to see DeltaRPM in action specifically.) I tried

# yum update --enablerepo=updates-testing gcompris gcompris-sound-hu

but there appear to be no updates yet. Is the command incorrect, or should I just wait for a bit longer?
Comment 13 Hans de Goede 2016-04-11 07:27:47 EDT
You just need to wait a bit longer. Note I'm also looking into fixing:
https://bugzilla.redhat.com/show_bug.cgi?id=1322031

Which I noticed only after creating the update so I'll likely do another update (obsoleting this one) soon.
Comment 14 Laszlo Ersek 2016-04-11 07:33:36 EDT
Okay, thanks. I'll subscribe to that bug too.
Comment 15 Fedora Update System 2016-04-11 09:43:43 EDT
gcompris-15.10-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-689871813e
Comment 16 Fedora Update System 2016-04-11 09:44:20 EDT
gcompris-15.10-6.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f00608f88a
Comment 17 Fedora Update System 2016-04-13 04:35:24 EDT
gcompris-15.10-6.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f00608f88a
Comment 18 Fedora Update System 2016-04-13 05:28:21 EDT
gcompris-15.10-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-689871813e
Comment 19 Laszlo Ersek 2016-04-13 06:18:15 EDT
I'm still not seeing anything beyond 15.10-2.fc22 in updates-testing :(
Comment 20 Laszlo Ersek 2016-04-14 05:44:21 EDT
Okay, I installed the update (gcompris-15.10-6.fc22). On my system the main package and the sound-hu subpackage are present. According to yum, DRPM turned the 138.8 MB download into an 1.1 MB download (saving 99.1%), when upgrading from 15.10-2.fc22. Also, audio works fine. I'll go provide some karma in Bodhi. Thanks, Hans!
Comment 21 Fedora Update System 2016-04-20 15:21:43 EDT
gcompris-15.10-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2016-04-21 21:50:08 EDT
gcompris-15.10-6.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.