Bug 1303424 - Verifying the Downloaded Image on Windows
Verifying the Downloaded Image on Windows
Status: CLOSED DUPLICATE of bug 1175759
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clayton Spicer
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 12:03 EST by Jakub Jelen
Modified: 2016-02-03 08:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 08:09:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelen 2016-01-31 12:03:23 EST
Description of problem:
Current guide proposes PowerShell script to verify checksum under windows, that requires to load the whole image into the memory. This is not ideal and might fail on systems with less RAM.

Version-Release number of selected component (if applicable):
fc23 so far

How reproducible:
on systems with not-enough available RAM

Steps to Reproduce:
1. run proposed commands from guide [1]

Actual results:
this might fail:

    $download_checksum = [System.BitConverter]::ToString($sha256.ComputeHash([System.IO.File]::ReadAllBytes("$PWD\$image"))).ToLower() -replace '-', ''


Expected results:
should work more effective:

    $stream = (Get-Item $filename).OpenRead()
    $hash = $sha256.ComputeHash($stream)
    $stream.Close()
    $download_checksum = [BitConverter]::ToString($hash).ToLower() -replace '-'

Source [2] with license:
 under cc by-sa 3.0 with attribution required


Additional info:
[1] https://docs.fedoraproject.org/en-US/Fedora/23/html/Installation_Guide/sect-verifying-images.html
[2] http://stackoverflow.com/a/35116369/2196426
Comment 1 Matthew Miller 2016-02-03 08:09:43 EST

*** This bug has been marked as a duplicate of bug 1175759 ***

Note You need to log in before you can comment on or make changes to this bug.