Bug 1303431 - Suspend not working for kernel 4.3.X
Suspend not working for kernel 4.3.X
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 12:38 EST by Kyle Kloberdanz
Modified: 2016-08-23 14:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:52:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Kloberdanz 2016-01-31 12:38:04 EST
Description of problem:
On a MacBook Pro 8,2 (Late 2011) when I either close the lid or hit the power button, the screen goes black, but the laptop gets very hot and the fans spin up. I cannot wake the screen at this point, and need to do a hard reboot.

This issue does not exist with kernel 4.2.x, only the 4.3 kernels

Version-Release number of selected component (if applicable):
Output of uname -a:
4.3.3-303.fc23.x86_64 #1 SMP Tue Jan 19 18:31:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Occurs nearly every time I either close the lid on my MacBook Pro 8,2 (Late 2011), or press the power button (which normally suspends the machine)


Steps to Reproduce:
1. Boot Fedora 23 using kernel 4.3.3
2. Close lid of MacBook Pro 8,2 (Late 2011)
3. Notice that the machine does not suspend (It gets very hot, and the screen remains off)

Actual results:
The laptop gets very hot, and the screen remains black


Expected results:
I expect it to suspend to ram, and for it to wake up when I reopen the lid

Additional info:

As a work around, I fallback to kernel 4.2.7, everything is working properly under that kernel. I only experience this problem under kernel 4.3.x

lspci:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:01.1 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Universal Host Controller #5 (rev 05)
00:1a.7 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Universal Host Controller #1 (rev 05)
00:1d.7 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM57765 Gigabit Ethernet PCIe (rev 10)
02:00.1 SD Host controller: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader (rev 10)
03:00.0 Network controller: Broadcom Corporation BCM4331 802.11a/b/g/n (rev 02)
04:00.0 FireWire (IEEE 1394): LSI Corporation FW643 [TrueFire] PCIe 1394b Controller (rev 08)
05:00.0 PCI bridge: Intel Corporation Device 1513
06:00.0 PCI bridge: Intel Corporation Device 1513
06:03.0 PCI bridge: Intel Corporation Device 1513
06:04.0 PCI bridge: Intel Corporation Device 1513
06:05.0 PCI bridge: Intel Corporation Device 1513
06:06.0 PCI bridge: Intel Corporation Device 1513
07:00.0 System peripheral: Intel Corporation Device 1513


lsusb:
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. Built-in IR Receiver
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 2.0 Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 001 Device 005: ID 05ac:0252 Apple, Inc. Internal Keyboard/Trackpad (ANSI)
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Comment 1 Michael Morgan 2016-03-02 18:00:10 EST
I have very similar behavior on a Dell Precision M3800 laptop. Any kernel from 4.3.3-300.fc23.x86_64 onward refuses to suspend consistently. Generally I can suspend once after a cold boot, resume, and any subsequent suspend will cause the screens to blank, fans spin up, and the only input accepted is a hard reboot from the power button. Suspend works properly consistently up to kernel 4.2.8-300.fc23.x86_64 .

Without fail journald will get up to:

Feb 26 01:04:02 mmorgan.localdomain systemd-sleep[4411]: Suspending system...

Then nothing. Successful suspends follow up with:

Mar 01 19:23:02 mmorgan.localdomain kernel: PM: Syncing filesystems ... done.
Mar 01 19:23:02 mmorgan.localdomain kernel: PM: Preparing system for sleep (mem)

The lack of feedback from the system makes it kind of hard to follow up on the issue. Not really sure where to dig next.
Comment 2 Kyle Kloberdanz 2016-03-02 18:04:37 EST
The problem is still present with kernel: 4.4.2
Comment 3 Kyle Kloberdanz 2016-03-30 19:00:28 EDT
This has been resolved with kernel 4.4.6-300.fc23.x86_64
Comment 4 Josh Boyer 2016-03-30 19:52:15 EDT
Thank you for letting us know.
Comment 5 mperdikeas 2016-08-23 14:16:05 EDT
I had exactly the same problem in a Dell Precision M3800 on both Ubuntu 14.04 and Ubuntu 16.04 (kernel 4.4.0). Updating to kernel 4.6.7-040607-generic fixed the issue for me.

Note You need to log in before you can comment on or make changes to this bug.