Bug 1303447 - [abrt] dnf: clean.py:85:_clean_filelist:TypeError: not all arguments converted during string formatting
[abrt] dnf: clean.py:85:_clean_filelist:TypeError: not all arguments converte...
Status: CLOSED DUPLICATE of bug 1303293
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:130877571e763cb84bcc53db249...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 14:16 EST by mastaiza
Modified: 2016-02-21 08:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 08:41:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (401.13 KB, text/plain)
2016-01-31 14:16 EST, mastaiza
no flags Details
File: backtrace (1.44 KB, text/plain)
2016-01-31 14:16 EST, mastaiza
no flags Details
File: environ (1.71 KB, text/plain)
2016-01-31 14:16 EST, mastaiza
no flags Details
File: dnf-makecache.log (10.99 MB, text/plain)
2016-01-31 14:17 EST, mastaiza
no flags Details

  None (edit)
Description mastaiza 2016-01-31 14:16:23 EST
Version-Release number of selected component:
dnf-1.1.6-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /bin/dnf clean all
executable:     /bin/dnf
kernel:         4.3.3-303.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
clean.py:85:_clean_filelist:TypeError: not all arguments converted during string formatting

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/clean.py", line 230, in run
    return self.clean(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/clean.py", line 184, in clean
    pkgcode, pkgresults = _clean_packages(repos)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/clean.py", line 114, in _clean_packages
    return _clean_files(repos, exts, 'pkgdir', 'package')
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/clean.py", line 98, in _clean_files
    return _clean_filelist(filetype, filelist)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/clean.py", line 85, in _clean_filelist
    msg %= (removed, filetype)
TypeError: not all arguments converted during string formatting

Local variables in innermost frame:
removed: 0
filetype: 'package'
filelist: []
msg: ''
Comment 1 mastaiza 2016-01-31 14:16:32 EST
Created attachment 1119920 [details]
File: _var_log_dnf.log
Comment 2 mastaiza 2016-01-31 14:16:33 EST
Created attachment 1119921 [details]
File: backtrace
Comment 3 mastaiza 2016-01-31 14:16:35 EST
Created attachment 1119922 [details]
File: environ
Comment 4 mastaiza 2016-01-31 14:17:35 EST
Created attachment 1119923 [details]
File: dnf-makecache.log
Comment 5 Michal Domonkos 2016-02-01 08:41:27 EST

*** This bug has been marked as a duplicate of bug 1303293 ***

Note You need to log in before you can comment on or make changes to this bug.