Bug 1303448 - Fedora 23 server installation fails on software RAID1
Fedora 23 server installation fails on software RAID1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: blivet-maint-list@redhat.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 14:43 EST by Elio Tondo
Modified: 2016-02-02 09:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 17:56:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Automatically generated by anaconda (124.62 KB, application/x-gzip)
2016-01-31 14:43 EST, Elio Tondo
no flags Details
ifcfg.log extracted from bug.tar.gz (5.92 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
dnf.rpm.log extracted from bug.tar.gz (49 bytes, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
packaging.log extracted from bug.tar.gz (3.09 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
anaconda.log extracted from bug.tar.gz (28.44 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
storage.log extracted from bug.tar.gz (152.90 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
syslog extracted from bug.tar.gz (97.11 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
program.log extracted from bug.tar.gz (47.17 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
dnf.log extracted from bug.tar.gz (5.91 KB, text/plain)
2016-02-01 09:42 EST, David Shea
no flags Details
anaconda-tb (467.76 KB, text/plain)
2016-02-01 09:43 EST, David Shea
no flags Details

  None (edit)
Description Elio Tondo 2016-01-31 14:43:03 EST
Created attachment 1119924 [details]
Automatically generated by anaconda

Description of problem:
Trying to install Fedora 23 Server x86_64 from DVD on a Dell T300 with two 1.5 TB HD and 20 GB RAM. Disks are pre-partitioned, each one with two primary partitions of type RAID autodetect (fd), one of 20 GB for / and the other with the remaining space for /home; sda1 and sdb1 are assembled to form md0, sda2 and sdb2 to form md1, both RAID1.
During installation there is no way to specify (like in old Fedora releases) that I want to create the RAID arrays and then to install on the first one.
I managed to see reasonable results in the partitioning screen only by working in a shell (Ctrl-Alt-F2) and doing the RAID setup manually. Then I correctly see md0 and I can assign it to / as its mount point, and I can specify to reformat it as ext4; all other options are greyed out.
The installation starts, but after a few seconds in fails with a traceback, that I managed to save on /tmp and later copy by manually configuring the network, to copy it on another server on the same LAN; it is attached.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Shea 2016-02-01 09:42:22 EST
Created attachment 1120125 [details]
ifcfg.log extracted from bug.tar.gz
Comment 2 David Shea 2016-02-01 09:42:26 EST
Created attachment 1120126 [details]
dnf.rpm.log extracted from bug.tar.gz
Comment 3 David Shea 2016-02-01 09:42:28 EST
Created attachment 1120127 [details]
packaging.log extracted from bug.tar.gz
Comment 4 David Shea 2016-02-01 09:42:31 EST
Created attachment 1120128 [details]
anaconda.log extracted from bug.tar.gz
Comment 5 David Shea 2016-02-01 09:42:33 EST
Created attachment 1120129 [details]
storage.log extracted from bug.tar.gz
Comment 6 David Shea 2016-02-01 09:42:36 EST
Created attachment 1120130 [details]
syslog extracted from bug.tar.gz
Comment 7 David Shea 2016-02-01 09:42:39 EST
Created attachment 1120131 [details]
program.log extracted from bug.tar.gz
Comment 8 David Shea 2016-02-01 09:42:41 EST
Created attachment 1120132 [details]
dnf.log extracted from bug.tar.gz
Comment 9 David Shea 2016-02-01 09:43 EST
Created attachment 1120133 [details]
anaconda-tb
Comment 10 David Lehman 2016-02-01 10:24:48 EST
The logs show the installer detecting /dev/md/0 (ext4) and /dev/md/1 (lvm pv). You didn't specify which commands you ran on tty2, nor did you say exactly what you saw that led you to believe you needed to go to tty2. Is it possible that the issue is confusion with the new storage configuration screen? Please take a look at the documentation and see if that helps:

https://docs.fedoraproject.org/en-US/Fedora/23/html/Installation_Guide/sect-installation-gui-manual-partitioning.html

To be clear, it is not going to be possible to create layered devices using pre-existing partitions. You must either let the installer create the partitions or create the volume group yourself.


If you are confident there is a bug here, please describe it in detail and provide some screenshots and/or logs to document it.
Comment 11 Elio Tondo 2016-02-01 17:56:42 EST
You are right; I was somewhat confused by the new configuration system, and I mistakenly followed some indications in this article: http://iranzo.github.io/blog/2015/03/28/install-rhel7-on-a-software-raid-device/ where it looked like the only way to install on RAID1 was to set up it manually.

I am now installing on a 20GB boot and root ext4 over RAID1 partition, created by only using the storage configuration screen. I will manually create the home partition later, after reboot (xfs over LVM over RAID1).

Thank you for the quick and very useful feedback, and sorry for the waste of time. Please close my report, since it's definitely not a bug.
Comment 12 David Lehman 2016-02-02 09:18:15 EST
I'm happy to hear you got it sorted out.

FWIW you should also be able to create your /home using the installer. You'd make the /home mountpoint, then change its device type to LVM, then set a raid level for the VG in the "Modify Volume Group" dialog, available from the right side while the /home mountpoint is selected on the left.

Note You need to log in before you can comment on or make changes to this bug.