Bug 130346 - Featurezilla: Escalate bug to feature (create new fz to correspond to bz)
Featurezilla: Escalate bug to feature (create new fz to correspond to bz)
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 09:58 EDT by dff
Modified: 2007-04-18 13:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.18-rh
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 18:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dff 2004-08-19 09:58:24 EDT
We frequently get RFEs submitted as bugs, or bug reports end up being not a bug
but a missing feature that a customer wants to request.

In these cases, we want to open a new Featurezilla to track the feature request
through our standard feature tracking processes.  Just converting the bug to a
feature is not really the desired outcome, because it looks really weird to the
outsider (Fz fields are mapped differently than Bz) and it may communicate false
hope to external users/customers -- e.g. when we put a feature into the RHEL3_U4
release in ASSIGN_TO_PM for evaluation, they may think it's committed for that
release, but many of those may never make it into ASSIGNED state.

The request is just a "create corresponding featurezilla" button that will open
a new featurezilla pre-populated with the necessary info from the bug and set up
the appropriate x-ref relationship between the two.

Suzanne Hillman and Jeff Needle frequently require this type of feature.
Comment 1 David Lawrence 2004-09-16 15:10:22 EDT
A sort of "Clone Bug/Feature" button. Sounds like a cool idea. Will look into
this for next build of bz.
Comment 2 David Lawrence 2004-12-09 18:27:07 EST
Close As Bug/Feature is enabled in beta and will be in final version. Please
reopen this bug if there is any problems.

Note You need to log in before you can comment on or make changes to this bug.