Bug 1303496 - Version negotiation in JDBC connection
Version negotiation in JDBC connection
Status: CLOSED WONTFIX
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: jolee
Filip Elias
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-31 23:21 EST by Hisanobu Okuda
Modified: 2017-05-15 15:46 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-15 15:46:49 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3946 Minor Resolved Version negotiation in JDBC connection 2017-11-22 09:26 EST

  None (edit)
Description Hisanobu Okuda 2016-01-31 23:21:21 EST
Description of problem:
Our customer is providing a service on top of JDV and some of the external clients are still using outdated teiid drivers and wants something they can make for JDV to block a connection if the JDBC Driver used in a client is outdated. This scenario occurs everytime the customer updates JDV. Since there are so much external clients, some of them don't update their JDBC Drivers and this leads to some errors in JDV.

Version-Release number of selected component (if applicable):
JDV 6.2.x

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 6 jolee 2017-05-15 15:46:49 EDT
This and TEIID-3946 and the associated case all lack the information to properly document what errors are being thrown.  I suggest we let the normal workflow occur here and an article be created when raised as an issue in SFDC and actual errors can be determined.

Note You need to log in before you can comment on or make changes to this bug.