Bug 1303510 - Change the copyright on all the Windows drivers to "2017" in virtio-win-prewhql build
Change the copyright on all the Windows drivers to "2017" in virtio-win-prewh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 01:43 EST by lijin
Modified: 2017-08-01 08:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:53:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copyright for qemupciserial (139.63 KB, image/png)
2017-04-19 01:50 EDT, Yu Wang
no flags Details

  None (edit)
Description lijin 2016-02-01 01:43:47 EST
Description of problem:
The copyright of *.inf,*.sys,License file in virtio-win-prewhql build is 2015,please update it to 2016


Version-Release number of selected component (if applicable):
virtio-win-prewhql-112

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Peixiu Hou 2016-02-03 22:38:12 EST
Hello,

Verified this issue on virtio-win-prewhql-113, the copyright of *.inf,*.sys, License file in build 113 package have been updated to 2016, the issue has been fixed.

Thanks~~

Best Regards!
Peixiu Hou
Comment 3 Yu Wang 2016-03-09 00:18:13 EST
According comment#2, the bug has been fixed, change the status to verified.

Thanks
Yu Wang
Comment 5 Yu Wang 2016-09-07 22:22:33 EDT
Hi,

retest on virtio-win-prewhql-126, all the copyright in netkvm.inf, is 2015 not 2016, should change to 2016.

So change the bug to assigned.

Thanks
Yu Wang
Comment 6 lijin 2016-09-10 01:31:50 EDT
Postpone to 7.4 as it's too late for rhel7.3
Comment 11 peliu@redhat.com 2017-03-17 04:01:53 EDT
Hi Vadim,

tried on build 134, some driver's copyright especially for netkvm still not right as below.

[ERR].\Wlh\amd64\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All rights reserved. 
[ERR].\Wlh\x86\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All rights reserved. 
no copyright in.\qemupciserial.inf
no copyright in.\Wnet\amd64\netkvm.inf
no copyright in.\Wnet\x86\netkvm.inf
no copyright in.\Wxp\x86\netkvm.inf

According to the latest document version,https://mojo.redhat.com/docs/DOC-1100497. We need the contents of the path \Wlh when testing netkvm driver in win2008, but the copyright information is not correct.
[ERR].\Wlh\amd64\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All rights reserved. 
[ERR].\Wlh\x86\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All rights
Please help to correct it.

Thanks & regards
Peizhen Liu
Comment 12 Vadim Rozenfeld 2017-03-24 23:55:10 EDT
(In reply to peliu@redhat.com from comment #11)
> Hi Vadim,
> 
> tried on build 134, some driver's copyright especially for netkvm still not
> right as below.
> 
> [ERR].\Wlh\amd64\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All
> rights reserved. 
> [ERR].\Wlh\x86\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All
> rights reserved. 
> no copyright in.\qemupciserial.inf
> no copyright in.\Wnet\amd64\netkvm.inf
> no copyright in.\Wnet\x86\netkvm.inf
> no copyright in.\Wxp\x86\netkvm.inf
> 
> According to the latest document
> version,https://mojo.redhat.com/docs/DOC-1100497. We need the contents of
> the path \Wlh when testing netkvm driver in win2008, but the copyright
> information is not correct.
> [ERR].\Wlh\amd64\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All
> rights reserved. 
> [ERR].\Wlh\x86\netkvm.inf: ; Copyright (c) 2008-2015 Red Hat, Inc.  All
> rights
> Please help to correct it.
> 
> Thanks & regards
> Peizhen Liu

Thanks a lot.
Fixed netkvm problems. The changes should be visible in the next build.
But I have some problems with qemupciserial, which is technically derived from .inf fiile provided by Microsoft. 

Yan, do you think it will be fine to add RH copyright statement into 
qemupciserial.inf file?

Thanks,
Vadim.
Comment 14 Vadim Rozenfeld 2017-04-12 01:57:12 EDT
please give a try to build 135 available at
http://download.eng.bos.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/135/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.
Comment 15 peliu@redhat.com 2017-04-17 02:40:22 EDT
Hi Vadim,

tried on build 135, all driver's copyright right.

Thanks & regards
Peizhen Liu
Comment 16 Vadim Rozenfeld 2017-04-17 04:00:20 EDT
Thank you a lot for the update.
Vadim.
Comment 18 Yu Wang 2017-04-19 01:50 EDT
Created attachment 1272477 [details]
copyright for qemupciserial
Comment 19 Vadim Rozenfeld 2017-05-01 07:29:27 EDT
It can be a problem. We have to check what to do with this case.
mf.sys is an in-box driver provided by Microsoft, and it is properly signed with MS signature. The .cat file is generated by ourselves and signed with RH cross signature. I'm not sure if we can submit that .cat file for WHQL signing.
Comment 20 lijin 2017-05-17 22:20:40 EDT
(In reply to Vadim Rozenfeld from comment #19)
> It can be a problem. We have to check what to do with this case.
> mf.sys is an in-box driver provided by Microsoft, and it is properly signed
> with MS signature. The .cat file is generated by ourselves and signed with
> RH cross signature. I'm not sure if we can submit that .cat file for WHQL
> signing.

I have submitted the driver to msft,all get approved.

change status to verified according to comment#15
Comment 23 errata-xmlrpc 2017-08-01 08:53:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341

Note You need to log in before you can comment on or make changes to this bug.