This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1303512 - [Docs] [Upgrade] Address feedback on the upgrade documentation
[Docs] [Upgrade] Address feedback on the upgrade documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: async
: 7.0 (Kilo)
Assigned To: Deepti Navale
Radek Bíba
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 02:02 EST by Andrew Dahms
Modified: 2016-04-13 00:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 00:51:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-02-01 02:02:21 EST
The following items must be addressed in Section 4.1 of Upgrading OpenStack:

* In Step 2.2, there is no database for Swift, and the openstack-db command
  does not work. This step must be confirmed.

* In Step 2.9, add a step to upgrade *\python-django\* as well.

* In Step 2.9, confirm why the second yum upgrade command is necessary after
  having run the first yum upgrade command. If unnecessary, remove.

* In Step 2.9, there is no database for Horizon, and the openstack-db command
  does not work. This step must be confirmed.

* In Step 2.9, the command 'openstack-service start horizon' command does not
  work. Confirm whether this is the correct command.
Comment 1 Andrew Dahms 2016-02-09 00:43:54 EST
Assigning to Deepti for review.
Comment 2 Deepti Navale 2016-02-16 18:33:21 EST
Hey Andrew, 

I've confirmed the following from Lars and updated based on his response as follows: 

> * In Step 2.2, there is no database for Swift, and the openstack-db command
>   does not work. This step must be confirmed.

the documented upgrade process boils down to:

- Stop things.
- Upgrade packages.
- Start things.

So commented out the db update command.

> 
> * In Step 2.9, add a step to upgrade *\python-django\* as well.

Included the python-django package for update command.

> 
> * In Step 2.9, confirm why the second yum upgrade command is necessary after
>   having run the first yum upgrade command. If unnecessary, remove.

This is necessary when performing a service-by-service upgrade,
because in this situation there is no initial "yum upgrade" of all
packages.

> 
> * In Step 2.9, there is no database for Horizon, and the openstack-db command
>   does not work. This step must be confirmed.

Removed db update command.

> 
> * In Step 2.9, the command 'openstack-service start horizon' command does not
>   work. Confirm whether this is the correct command.

Replaced the 'openstack-service start horizon' with 'systemctl restart httpd' command.
Comment 5 Andrew Dahms 2016-04-13 00:51:00 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.