Bug 1303518 - After restart of the opendaylight service networks list is empty
After restart of the opendaylight service networks list is empty
Status: CLOSED DUPLICATE of bug 1303520
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Toni Freger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 02:50 EST by Itzik Brown
Modified: 2016-02-04 08:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 08:51:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itzik Brown 2016-02-01 02:50:12 EST
Description of problem:
After restarting opendaylight service and running the following:

curl -H "Content-Type:application/json" -u admin:admin http://127.0.0.1:8080/controller/nb/v2/neutron/networks

The output is:
{
   "networks" : [ ]
}

Even though the networks exist on Neutron.
After creating another network the above command shows all the networks.

Version-Release number of selected component (if applicable):
opendaylight-0.1.1-4.el7ost.noarch
python-networking-odl-1.0.1-1.el7ost.noarch
python-neutron-7.0.0-5.el7ost.noarch
openstack-neutron-7.0.0-5.el7ost.noarch
openstack-neutron-ml2-7.0.0-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a network
2. Verify that you can see the network when querying the ODL controller
   # curl -H "Content-Type:application/json" -u admin:admin http://<ODL controller IP>:8080/controller/nb/v2/neutron/networks
3. Restart the ODL controller
4. Verify output of the command in #2 shows no network 

Actual results:


Expected results:


Additional info:
Comment 2 Nir Yechiel 2016-02-04 08:51:48 EST

*** This bug has been marked as a duplicate of bug 1303520 ***

Note You need to log in before you can comment on or make changes to this bug.