Bug 1303529 - [docs] Dev guide - application health check HTTP status codes incorrect
[docs] Dev guide - application health check HTTP status codes incorrect
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
https://access.redhat.com/documentati...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 03:20 EST by Evgheni Dereveanchin
Modified: 2017-12-24 16:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-24 16:46:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgheni Dereveanchin 2016-02-01 03:20:41 EST
Document URL: 
https://access.redhat.com/documentation/en/openshift-enterprise/3.1/developer-guide/chapter-24-application-health

Section Number and Name: 
24.2. CONTAINER HEALTH CHECKS USING PROBES

 HTTP Checks

Describe the issue: 

 Here's the downstream descriptions of error codes:
  The check is deemed successful if the hook returns with 200 or 399.

 Here's the upstream description however (which is linked on the same page):
   If it returns between 200 and 399, it is considered success, failure otherwise.

 So any status code in the range from 200 to 399 is deemed "success" by kubernetes.

Suggestions for improvement: 

Fix the sentence as all 2xx and 3xx codes are "success" and there seems to be a typo.

Additional information: 
 Upstream doc:
  http://kubernetes.io/v1.0/docs/user-guide/walkthrough/k8s201.html#health-checking

 HTTP Status Codes:
  https://en.wikipedia.org/wiki/List_of_HTTP_status_codes#2xx_Success
  https://en.wikipedia.org/wiki/List_of_HTTP_status_codes#3xx_Redirection

Note You need to log in before you can comment on or make changes to this bug.