Bug 1303530 - Start time of opendaylight service is more than a minute
Start time of opendaylight service is more than a minute
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Toni Freger
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 03:31 EST by Itzik Brown
Modified: 2016-08-17 10:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-17 10:01:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itzik Brown 2016-02-01 03:31:33 EST
Description of problem:
After starting the opendaylight service and running:

curl -H "Content-Type:application/json" -u admin:admin http://127.0.0.1:8081/controller/nb/v2/neutron/networks

First I get "connection refused" error
After a while I get:
{"error":"Authentication service unavailable"}
After a minute there is a normal output 

Version-Release number of selected component (if applicable):
opendaylight-0.1.1-4.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Start the opendaylight service
2. Run the following command:
# curl -H "Content-Type:application/json" -u admin:admin http://127.0.0.1:8081/controller/nb/v2/neutron/networks


Actual results:


Expected results:


Additional info:
Comment 2 Nir Yechiel 2016-08-17 10:01:21 EDT
Closing as not a bug; When ODL starts or restarts all the karaf features need to be loaded one by one and it's going to take some time. I think we should be OK as long as it takes a couple of minutes

Note You need to log in before you can comment on or make changes to this bug.