Bug 1303538 - ImportError: No module named runmote
ImportError: No module named runmote
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mote (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chaoyi Zha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 03:50 EST by Parag Nemade
Modified: 2016-02-01 15:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 15:22:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2016-02-01 03:50:33 EST
Description of problem:
I was looking for some binary in /usr/bin and found mote. so thought let's try what this mote provides. I get this
$ mote --help
Traceback (most recent call last):
  File "/usr/bin/mote", line 9, in <module>
    load_entry_point('mote==0.4.2', 'console_scripts', 'mote')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 558, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2355, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2361, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
ImportError: No module named runmote


Version-Release number of selected component (if applicable):
mote-0.4.3-2.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1.mote --help
2.
3.

Actual results:
traceback as given above

Expected results:
should not give traceback or pull required packages automatically.

Additional info:
Comment 1 Chaoyi Zha 2016-02-01 15:22:57 EST
What specifically were you trying to achieve? The mote package adds its configuration to Apache, and uses mod_wsgi to execute the Python application.

It looks like the mote binary was trying to run the development server that comes with Flask, but it isn't really the point of the package. For development, it is preferable to clone the Git repository and run `runmote.py` from there. I think I may remove this, because it doesn't serve much purpose in the context of the package, meant to be ran on Fedora infrastructure or in production.

You can use gunicorn to run mote if you don't want to use mod_wsgi and Apache.

Note You need to log in before you can comment on or make changes to this bug.