Bug 1303551 - the go-md2man is not a correct BuildRequires in atomic SPEC file
the go-md2man is not a correct BuildRequires in atomic SPEC file
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 04:52 EST by Alex Jia
Modified: 2016-02-16 15:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 15:23:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Jia 2016-02-01 04:52:28 EST
Description of problem:
We only have a golang-github-cpuguy83-go-md2man RPM package in brew system, but the atomic needs a go-md2man BuildRequires in SPEC file.

Version-Release number of selected component (if applicable):
atomic-1.8-6.git1bc3814.el7.src.rpm

How reproducible:
always

Steps to Reproduce:
1. rpm -ivh atomic-1.8-6.git1bc3814.el7.src.rpm
2. grep go- /root/rpmbuild/SPECS/atomic.spec


Actual results:

# grep go- /root/rpmbuild/SPECS/atomic.spec
BuildRequires: go-md2man

Expected results:
BuildRequires: /usr/bin/go-md2man    (Daniel suggests this)

OR

BuildRequires: golang-github-cpuguy83-go-md2man


Additional info:

The k8s has a BuildRequires looks like this.
BuildRequires: golang-github-cpuguy83-go-md2man
Comment 2 Lokesh Mandvekar 2016-02-01 10:18:26 EST
hmm, golang-github-cpuguy83-go-md2man should have a "Provides: go-md2man" which should take care of this bug, but I'll look what's up.
Comment 3 Lokesh Mandvekar 2016-02-01 10:39:28 EST
I don't see any issue with the way we're specifying BuildRequires: go-md2man (see paste below). Is there some other problem that's caused because of this?


$ sudo yum-builddep atomic.spec
Getting requirements for atomic.spec
 --> Already installed : python-devel-2.7.5-34.el7.x86_64
 --> Already installed : python-requests-2.6.0-1.el7_1.noarch
 --> Already installed : python-setuptools-0.9.8-4.el7.noarch
 --> Already installed : python-tools-2.7.5-34.el7.x86_64
 --> Already installed : dbus-python-1.1.1-9.el7.x86_64
 --> Already installed : policycoreutils-python-2.2.5-20.el7.x86_64
 --> golang-github-cpuguy83-go-md2man-1.0.4-1.el7.x86_64
 --> Already installed : python-docker-py-1.6.0-1.el7.noarch
 --> Already installed : rpm-python-4.11.3-17.el7.x86_64
--> Running transaction check
---> Package golang-github-cpuguy83-go-md2man.x86_64 0:1.0.4-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================================
 Package                                              Arch                       Version                         Repository                                 Size
=================================================================================================================================================================
Installing:
 golang-github-cpuguy83-go-md2man                     x86_64                     1.0.4-1.el7                     External-Repository-2                     558 k

Transaction Summary
=================================================================================================================================================================
Install  1 Package

Total download size: 558 k
Installed size: 2.3 M
Is this ok [y/d/N]: y
Downloading packages:
golang-github-cpuguy83-go-md2man-1.0.4-1.el7.x86_64.rpm                                                                                   | 558 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : golang-github-cpuguy83-go-md2man-1.0.4-1.el7.x86_64                                                                                           1/1 
  Verifying  : golang-github-cpuguy83-go-md2man-1.0.4-1.el7.x86_64                                                                                           1/1 

Installed:
  golang-github-cpuguy83-go-md2man.x86_64 0:1.0.4-1.el7                                                                                                          

Complete!
Comment 4 Lokesh Mandvekar 2016-02-01 10:45:16 EST
Also, see the mock logs for the build scheduled for release https://download.eng.bos.redhat.com/brewroot/packages/atomic/1.8/6.git1bc3814.el7/data/logs/x86_64/root.log <- golang-github-cpuguy83-go-md2man was correctly picked up as a build dep.

Note You need to log in before you can comment on or make changes to this bug.