Bug 130356 - PATH_TRANSLATED is not just a translated version of PATH_INFO when a index file is inside the PATH_INFO directory
Summary: PATH_TRANSLATED is not just a translated version of PATH_INFO when a index fi...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-19 15:37 UTC by Roger Pena-Escobio
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 13:01:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script to test the PATH_INFO and the PATH_TRANSLATED enviroment variables (433 bytes, text/plain)
2004-08-19 15:40 UTC, Roger Pena-Escobio
no flags Details

Description Roger Pena-Escobio 2004-08-19 15:37:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040602

Description of problem:
when i need the PATH_TRANSLATED information in a CGI but also have a
valid Index page inside the PATH_INFO directory, the variable will not
be a translated version of PATH_INFO, i will get the file name of
index page added to the end of the translated version of PATH_INFO:
like this:

PATH_TRANSLATED :/var/www/html/conf/index.html
PATH_INFO :/conf/ 

if i don't have any valid Index page i get the right values:

PATH_TRANSLATED :/var/www/html/conf/
PATH_INFO :/conf/ 

according to http://hoohoo.ncsa.uiuc.edu/cgi/env.html, which is
reference from  http://httpd.apache.org/docs-2.0/howto/cgi.html,
PATH_TRANSLATED is, and i cuote, 
"a translated version of PATH_INFO, which takes the path and does any
virtual-to-physical mapping to it"



Version-Release number of selected component (if applicable):
httpd-2.0.46-32.ent.3

How reproducible:
Always

Steps to Reproduce:
1. put the example perl cgi i provide into the cgi-bin directory.
2. create a a new directory into the Document Root, for example test.
3. create a valid Index page into the new directory, for example
execute the command: touch index.html
4. call the CGI passing a referense directory from a browser, for
example: http://localhost/cgi-bin/cgi-perl.pl/test/
    

Actual Results:  Checking enviroment variables
PATH_TRANSLATED :/var/www/html/test/index.html
PATH_INFO :/test/

Expected Results:  Checking enviroment variables
PATH_TRANSLATED :/var/www/html/test/
PATH_INFO :/test/

Additional info:

Comment 1 Roger Pena-Escobio 2004-08-19 15:40:29 UTC
Created attachment 102880 [details]
script to test the PATH_INFO and the PATH_TRANSLATED enviroment variables

this script is the perl cgi used by me to easy show the problem i'm reporting

Comment 2 Joe Orton 2004-09-06 13:01:36 UTC
Thanks for the report.  Per the discussion on the
users@httpd.apache.org mailing list:

http://marc.theaimsgroup.com/?l=apache-httpd-users&m=109300814330651&q=raw

mod_dir in 2.0 causes a different PATH_TRANSLATED than 1.3 since it is
run at a different stage in the request processing.


Note You need to log in before you can comment on or make changes to this bug.