Bug 1303565 - livecd-creator fails to build iso, if semodule is only available inside the chroot
livecd-creator fails to build iso, if semodule is only available inside the c...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 05:13 EST by Fabian Deutsch
Modified: 2016-06-14 16:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-14 16:16:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2016-02-01 05:13:19 EST
Description of problem:
If livecd-creator is creating an iso from packageset which also includes a custom selinux policy which is not installed on the host, then livecd-creator fails, because the relabeling inside the chroot fails.

To fix bug 1121301 a check was added to fail if enforcing mode is set in the kickstart. This is maybe semantically not good, because the kickstart describes the requirement on the runtime, and should not have this direct affect at build time.
I understand why the fix was introduced, but it should be implemented different. I.e. add a switch to livecd-creator to fail on this kind of a problem.

Version-Release number of selected component (if applicable):
RHEL 7.2
CentOS 7.2

livecd-tools-21.4-2.el7

How reproducible:
Always

Steps to Reproduce:
1. Create a kickstart which includes an selinux module which is not used on the build host
2. Run livecd-creator
3.

Actual results:
iso build fails

Expected results:
iso build succeeds

Additional info:
- This looks like a regression of bug 1121301
- This is filed in CentOS as well: https://bugs.centos.org/view.php?id=10243
- There is a patch which reverts the fix for 1121301: https://github.com/tlitovsk/livecd-tools/commit/247ccd1d860aefa231e0216d450559b777d77408
Comment 7 RHEL Product and Program Management 2016-06-14 16:16:28 EDT
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.