Bug 1303567 - Overcloud deployment fails using Ceph
Overcloud deployment fails using Ceph
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-tripleo-image-elements (Show other bugs)
trunk
x86_64 Linux
unspecified Severity high
: ---
: trunk
Assigned To: James Slagle
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 05:28 EST by Ido Ovadia
Modified: 2017-06-18 02:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:13:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ido Ovadia 2016-02-01 05:28:00 EST
Description of problem:
========================
Mitaka: 
Overcloud deployment fails because image building does not include ceph.
The quickstart images do not include ceph


Version-Release number of selected component:
=============================================
Mitaka, Milestone2

How reproducible:
=================
100%


Steps to Reproduce:
===================
1. Deploy undercloud on CentOS 7.1.1503 using RDO menager
   https://www.rdoproject.org/testday/mitaka/milestone2/

2. Deploy the Overcloud:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --ceph-storage-scale 1 --ntp-server clock.redhat.com -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml --libvirt-type qemu


Actual results:
===============
Overcloud deployment failed with code: 6 Overcloud deployment fails because image building does not include ceph repo.

Expected results:
=================
Images should include ceph repo and overcloud successfully deployed


Additional info:
================
Successfully deploy with the following patch

https://review.gerrithub.io/#/c/261510/1/playbooks/roles/images/base/templates/repos/centos7-mitaka-delorean
Comment 2 Christopher Brown 2017-06-17 15:02:12 EDT
Long since fixed. This bug should be closed.

Note You need to log in before you can comment on or make changes to this bug.