Bug 130357 - High iowait and system load w/ moderate disk io
Summary: High iowait and system load w/ moderate disk io
Status: CLOSED DUPLICATE of bug 121434
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-19 15:43 UTC by Jason W. Mitchell
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/cpuinfo (881 bytes, text/plain)
2004-08-19 15:49 UTC, Jason W. Mitchell
no flags Details
lspci output (6.00 KB, text/plain)
2004-08-19 15:51 UTC, Jason W. Mitchell
no flags Details

Description Jason W. Mitchell 2004-08-19 15:43:53 UTC
Description of problem:
- High iowait and cpu load w/ moderate disk io.  
- Similar to bug 129545 and bug121434, but critical difference 
  it that the system lacks RAID completely, but is still SMP.  
- Problem occurs if using either SMP or UP kernels listed below.
- during high iowait and lockup, kswapd is grabbing nearly all
  of the CPU

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-15.EL
kernel-smp-2.4.21-15.0.4.EL
kernel-smp-2.4.21-18.EL

System:
- Red Hat Enterprise Linux WS release 3 (Taroon Update 2); up2date
  current 2004/08/19
- ASLAB dual Athlon 1900; two IDE disks, separate channels.
- more info will be attached

How reproducible:
tar cf junk.tar /usr
watch top and feel the machine grind to a hault

Steps to Reproduce:
1.
2.
3.
  
Actual results:
machine grinds to hault and becomes unusable, or may crash completely

Expected results:
machine should not grind to hault with moderate disk io, should not
crash from moderate disk io.

Additional info:
- Temporary solution is to use Fedora Core 1: 
  kernel-smp-2.4.22-1.2199.nptl.athlon.rpm.
- tweaking a wide range of /proc/sys/vm/{min,max}-readahead failed
  to solve the problem

Comment 1 Jason W. Mitchell 2004-08-19 15:49:32 UTC
Created attachment 102881 [details]
/proc/cpuinfo

Comment 2 Jason W. Mitchell 2004-08-19 15:51:02 UTC
Created attachment 102882 [details]
lspci output

Comment 3 Doug Ledford 2004-09-02 20:56:03 UTC
This sounds like a dup of 121434 to me.  Marking as such.

*** This bug has been marked as a duplicate of 121434 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:05:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.