Bug 1303599 - The python3-solv RPM requires both Python 2 and Python 3.
Summary: The python3-solv RPM requires both Python 2 and Python 3.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: 24
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3
TreeView+ depends on / blocked
 
Reported: 2016-02-01 12:13 UTC by Charalampos Stratakis
Modified: 2016-04-09 09:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-09 09:43:03 UTC


Attachments (Terms of Use)

Description Charalampos Stratakis 2016-02-01 12:13:19 UTC
The python3-solv RPM requires both Python 2 and Python 3.

Except in very special circumstances, there is no need for one package
to drag in both Python stacks. This is a packaging error:  a stray "/usr/bin/python" shebang in an example file: /usr/share/doc/python3-solv/pysolv.

Please remove the stray dependency.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing this issue!

Comment 1 Charalampos Stratakis 2016-02-24 11:59:25 UTC
Ping?

Any update on that?

Comment 2 Jan Kurik 2016-02-24 15:39:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 3 Igor Gnatenko 2016-04-09 09:43:03 UTC
now we don't ship any docs like pysolv for quite some time, so closing this. (at least for f24+)

Thanks for notification!


Note You need to log in before you can comment on or make changes to this bug.