Bug 1303615 - OSPd 7.3 IPV6 | HA with External LB fails to deploy because failure to parse IPv6 address.
OSPd 7.3 IPV6 | HA with External LB fails to deploy because failure to parse ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: z4
: 7.0 (Kilo)
Assigned To: Emilien Macchi
Leonid Natapov
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 08:08 EST by Leonid Natapov
Modified: 2016-04-11 07:41 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-48.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:45:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
extrnal lb yaml file (2.07 KB, text/plain)
2016-02-01 08:08 EST, Leonid Natapov
no flags Details
haproxy file (7.72 KB, text/plain)
2016-02-01 08:08 EST, Leonid Natapov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 275850 None None None 2016-02-03 12:28 EST

  None (edit)
Description Leonid Natapov 2016-02-01 08:08:10 EST
Created attachment 1120094 [details]
extrnal lb yaml file

Description of problem:
HA with External LB fails to deploy because failure to parse IPv6 address.
----------------------------------------


Stack failed with status: Resource CREATE failed: Error: resources.ControllerNodesPostDeployment.resources.ControllerOvercloudServicesDeployment_Step6.resources[0]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6
ERROR: openstack Heat Stack create failed.
[stack@puma42 ~]$ heat resource-list -n5  overcloud | grep -v COMPLETE
+----------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+----------------------+----------------------------------------------+
| resource_name                                | physical_resource_id                          | resource_type                                     | resource_status | updated_time         | parent_resource                              |
+----------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+----------------------+----------------------------------------------+
| ControllerNodesPostDeployment                | f3994a61-bd2d-4572-96c2-8ff9724f57f7          | OS::TripleO::ControllerPostDeployment             | CREATE_FAILED   | 2016-02-01T12:01:49Z |                                              |
| ControllerOvercloudServicesDeployment_Step6  | 99948a02-5056-4b56-a272-3ed9847e896d          | OS::Heat::StructuredDeployments                   | CREATE_FAILED   | 2016-02-01T12:15:51Z | ControllerNodesPostDeployment                |
| 0                                            | 056b912e-2825-43b6-8b8e-a3df33c4df08          | OS::Heat::StructuredDeployment                    | CREATE_FAILED   | 2016-02-01T12:33:07Z | ControllerOvercloudServicesDeployment_Step6  |
+----------------------------------------------+-----------------------------------------------+---------------------------------------------------+-----------------+----------------------+----------------------------------------------+

Deployment fails with the following error:ERROR: openstack Failed to parse: 2620:52:0:23a9::25:35357\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Keystone::Roles::Admin/Keystone_user[admin]: Skipping because of failed dependencies\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Keystone::Roles::Admin/Keystone_user_role[admin@admin]: Skipping because of failed dependencies\u001b[0m\n\u001b[1;31mWarning: /Stage[main]/Heat::Keystone::Domain/Exec[heat_domain_create]: Skipping because of failed dependencies\u001b[0m\n", 




Attached haproxy file from load balance machine and external_lb-v6.yaml file from undercloud machine

Here is the deployment command:
openstack overcloud deploy --templates -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation-v6.yaml -e /home/stack/network-environment-v6.yaml --control-scale 3 --compute-scale 1 --neutron-network-type vlan --neutron-tunnel-types vlan --neutron-network-vlan-ranges datacentre:221:241 --neutron-disable-tunneling --timeout 180 --ntp-server clock.redhat.com -e /usr/share/openstack-tripleo-heat-templates/environments/external-loadbalancer-vip-v6.yaml -e external_lb-v6.yaml
Comment 2 Leonid Natapov 2016-02-01 08:08 EST
Created attachment 1120095 [details]
haproxy file
Comment 3 marios 2016-02-03 05:56:37 EST
Can you please check on the controller node - would be nice to get the full trace from where this fails exactly (like in /var/log/messages for example)
Comment 17 Leonid Natapov 2016-02-11 10:20:03 EST
openstack-puppet-modules-2015.1.8-49.el7ost.noarch

Fixed.

Deployment successfully finished.
Comment 20 errata-xmlrpc 2016-02-18 11:45:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0265.html

Note You need to log in before you can comment on or make changes to this bug.