Bug 1303621 - [GCC 6.0] Firefox fails to build
[GCC 6.0] Firefox fails to build
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 08:23 EST by Martin Stransky
Modified: 2016-02-04 19:21 EST (History)
3 users (show)

See Also:
Fixed In Version: firefox-44.0-5.fc23 firefox-44.0-5.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 18:22:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1245076 None None None 2016-02-02 07:56 EST

  None (edit)
Description Martin Stransky 2016-02-01 08:23:46 EST
Description of problem:

Rawhide firefox fails to build with new shiny gcc 6.0.
Comment 1 Martin Stransky 2016-02-02 07:46:01 EST
That's because "/usr/include/c++/6.0.0/stdlib.h" is included instead of "/usr/include/stdlib.h". /usr/include/c++/6.0.0/stdlib.h is a new file added to gcc 6.0.

Fails (6.0.0):
# 2 "../../dist/system_wrappers/stdlib.h" 3
# 1 "/usr/include/c++/6.0.0/stdlib.h" 1 3
# 1 "../../dist/stl_wrappers/cstdlib" 1 3

Ok (5.x)
# 2 "../../dist/system_wrappers/stdlib.h" 3
# 1 "/usr/include/stdlib.h" 1 3 4
Comment 2 Martin Stransky 2016-02-02 07:56:42 EST
Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1245076
Comment 3 Fedora Update System 2016-02-03 04:35:13 EST
firefox-44.0-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d73684df54
Comment 4 Fedora Update System 2016-02-03 04:35:13 EST
firefox-44.0-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8344bd0b61
Comment 5 Fedora Update System 2016-02-03 04:35:16 EST
firefox-44.0-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8344bd0b61
Comment 6 Fedora Update System 2016-02-03 18:00:28 EST
firefox-44.0-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8344bd0b61
Comment 7 Fedora Update System 2016-02-03 18:25:28 EST
firefox-44.0-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d73684df54
Comment 8 Fedora Update System 2016-02-04 18:22:11 EST
firefox-44.0-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-02-04 19:21:03 EST
firefox-44.0-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.