Bug 1303653 - hammer sc-params --hostgroup option do not work with --hostgroup-id option. Error "missing param 'hostgroup_id' in parameters"
Summary: hammer sc-params --hostgroup option do not work with --hostgroup-id option. E...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.6
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-01 15:12 UTC by Mahesh Taru
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:01:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Mahesh Taru 2016-02-01 15:12:11 UTC
Description of problem:
With hammer CLI trying to get sc-params details of hostgroup fails with error "missing param hostgroup_id' in parameters" when trying using options --hostgroup and --hostgroup-id.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli-0.1.4.13-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to get sc-params of hostgroup using hammer CLI.

# hammer hostgroup sc-params --hostgroup <hostgroup-name> --hostgroup-id <hostgroup-id>
missing param 'hostgroup_id' in parameters

2. --hostgroup-id option do not work with --name too.

# hammer hostgroup sc-params --name <hostgroup-name> --hostgroup-id <hostgroup-id>
Error: 400 Bad Request

3. It do not work alone too as like --id option.

# hammer hostgroup sc-params --hostgroup-id <hostgroup-id>
missing param 'hostgroup_id' in parameters


Actual results:
missing param 'hostgroup_id' in parameters
Error: 400 Bad Request

Expected results:
It should work as like --id option.

Additional info:

Comment 2 Brad Buckingham 2016-03-01 20:29:40 UTC
Created redmine issue http://projects.theforeman.org/issues/13995 from this bug

Comment 3 Bryan Kearney 2016-03-01 21:00:51 UTC
Upstream bug component is Provisioning

Comment 4 Brad Buckingham 2016-03-02 11:06:29 UTC
Based on the comment on the upstream redmine, I am moving this to ON_QA for verification against Satellite 6.2.

Comment 6 Jitendra Yejare 2016-04-14 11:27:34 UTC
Verified this in Sat 6.2 snap 8.1.

The issue is no more reproducible.

All the said commands in Description are working as expected.

1. hammer hostgroup sc-params --hostgroup hg1 --hostgroup-id 1
---|-----------|---------------|----------|-------------
ID | PARAMETER | DEFAULT VALUE | OVERRIDE | PUPPET CLASS
---|-----------|---------------|----------|-------------

2. hammer hostgroup sc-params --name hg1 --hostgroup-id 1
Error: Unrecognised option '--name'

3. hammer hostgroup sc-params --hostgroup-id 1
---|-----------|---------------|----------|-------------
ID | PARAMETER | DEFAULT VALUE | OVERRIDE | PUPPET CLASS
---|-----------|---------------|----------|-------------

Only the second command having --name option is not testable as --name option is removed from listing hostgroup sc-params from hammer.

So moving to verified.

Comment 8 errata-xmlrpc 2016-07-27 09:01:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.