Bug 1303664 - Floating IP fails to reach status 'ACTIVE'
Floating IP fails to reach status 'ACTIVE'
Status: CLOSED DUPLICATE of bug 1284739
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Toni Freger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 10:36 EST by Nicolas Auvray
Modified: 2016-10-04 00:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 11:24:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Auvray 2016-02-01 10:36:42 EST
Description of problem:

When running Tempest smoke tests against a 7.2 OSP infrastructure, one test (test_network_basic_ops) fails with this error:

MismatchError: 'ACTIVE' != None: FloatingIP: <"FloatingIP" addr="X.X.X.X" id="dbe10652-b121-42e8-b9ad-4ac99708b0fd"> is at status: None. failed  to reach status: ACTIVE

I can reproduce the problem by hand by creating a floating IP and associating it to a Nova instance. The status is DOWN when the floating IP is not attached to any instance, and <null> when attached. In the database :

MariaDB [ovs_neutron]> select * from floatingips\G
*************************** 1. row ***************************
           tenant_id: 139b420a84dd416d872e086a53f17646
                  id: dcdb1a94-e5f5-4aba-94af-7f99453ff1c5
 floating_ip_address: X.X.X.X
 floating_network_id: 0d1536fb-0781-48bc-855b-85cb88d344bf
    floating_port_id: 3d41e436-eabf-4227-af82-8b5bdeebae17
       fixed_port_id: 7d43f375-f3e9-4ac1-b726-97739eac409d
    fixed_ip_address: 10.40.42.58
           router_id: b0937323-4170-4962-81c4-fd6018dcfb9d
last_known_router_id: NULL
              status: NULL


One interesting thing is that the floating IP is reachable when attached :

[stack@hidden tempest]$ telnet X.X.X.X 22
Trying X.X.X.X...
Connected to X.X.X.X.
Escape character is '^]'.
SSH-2.0-dropbear_2012.55



Version-Release number of selected component (if applicable):

openstack-neutron-2015.1.2-6.el7ost.noarch



Actual results:

Associated floating IPs have status NULL in Neutron DB.


Expected results:

Associated floating IPs should have status ACTIVE in Neutron DB.
Comment 2 Assaf Muller 2016-02-01 11:24:10 EST

*** This bug has been marked as a duplicate of bug 1284739 ***

Note You need to log in before you can comment on or make changes to this bug.