Bug 1303680 - openscap-1.0.* does not seem to be able to produce the HTML report when evaluating OVAL document directly
openscap-1.0.* does not seem to be able to produce the HTML report when evalu...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Černý
Marek Haicman
:
Depends On: 1258958
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 11:29 EST by Marek Haicman
Modified: 2016-11-03 23:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: openscap-1.2.9-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258958
Environment:
Last Closed: 2016-11-03 23:33:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Marek Haicman 2016-08-09 11:33:55 EDT
Confirmed fix on version openscap-1.2.10-1.el7.x86_64


===
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   openscap-1.2.10-1.el7.x86_64
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Report creation (bz1258958, bz1303680)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'oscap oval eval --report report_straight.html /tmp/tmp.vh0ikhBQdz/oval.xml' (Expected 0, got 0)
:: [   PASS   ] :: File 'report_straight.html' should contain 'XHTML' 
:: [   PASS   ] :: Command 'oscap oval eval --results results_step.xml /tmp/tmp.vh0ikhBQdz/oval.xml' (Expected 0, got 0)
:: [   PASS   ] :: File 'results_step.xml' should contain '<oval_results' 
:: [   PASS   ] :: Command 'oscap oval generate report --output report_step.html results_step.xml' (Expected 0, got 0)
:: [   PASS   ] :: File 'report_step.html' should contain 'XHTML' 
:: [   LOG    ] :: Duration: 0s
:: [   LOG    ] :: Assertions: 6 good, 0 bad
:: [   PASS   ] :: RESULT: Report creation (bz1258958, bz1303680)
Comment 6 errata-xmlrpc 2016-11-03 23:33:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2316.html

Note You need to log in before you can comment on or make changes to this bug.