Bug 1303681 - openstack overcloud deploy should never generate new passwords for a stack update.
Summary: openstack overcloud deploy should never generate new passwords for a stack up...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jason E. Rist
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks: 1304324
TreeView+ depends on / blocked
 
Reported: 2016-02-01 16:31 UTC by Dougal Matthews
Modified: 2016-12-14 15:21 UTC (History)
15 users (show)

Fixed In Version: python-tripleoclient-5.2.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1304324 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:21:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 275661 None None None 2016-02-03 12:20:21 UTC
Launchpad 1541342 None None None 2016-02-03 12:19:40 UTC

Description Dougal Matthews 2016-02-01 16:31:49 UTC
Description of problem:

The command openstack overcloud deploy generates passwords when it is first executed and stores them in file. If the user then changes to another directory and re-runs the deploy, it will perform a stack update but generate the passwords again.

Steps to Reproduce:
1. openstack overcloud deploy
2. cd /tmp (or anywhere other than the CWD)
3. openstack overcloud deploy

Actual results:

Passwords are re-generated and sent to Heat again, which attempts to reconfigure the passwords on all services.


Expected results:

Passwords should never be generated on a stack update, the command should complain loudly that the password file can't be found.

Related:
https://bugzilla.redhat.com/show_bug.cgi?id=1303246

Comment 2 Ryan Brown 2016-02-01 17:16:04 UTC
When you say "complain loudly" are you asking for it to stop & not do the update, or should it prompt the user for permission to continue?

Comment 3 Dougal Matthews 2016-02-01 19:11:13 UTC
(In reply to Ryan Brown from comment #2)
> When you say "complain loudly" are you asking for it to stop & not do the
> update, or should it prompt the user for permission to continue?

I think it should probably stop and not do the update. If anyone has a compelling reason we could add a flag to continue anyway.

Comment 6 Mike Burns 2016-04-07 21:07:13 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 8 Jason E. Rist 2016-10-05 17:21:00 UTC
I believe this has been merged as of 8 months ago https://review.openstack.org/#/c/275661/

Comment 11 Ana Krivokapic 2016-11-22 15:51:24 UTC
The passwords file is no longer being generate; the passwords are stored in Mistral now. We should still make sure that the passwords are not being re-generated and overwritten on stack updates.

Comment 12 Ana Krivokapic 2016-11-22 17:15:36 UTC
Works in python-tripleoclient-5.3.0-7.el7ost.noarch

Comment 14 errata-xmlrpc 2016-12-14 15:21:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.