Bug 1303683 - dogtag should support GSSAPI based auth in conjuction with FreeIPA
Summary: dogtag should support GSSAPI based auth in conjuction with FreeIPA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 7.4
Assignee: Fraser Tweedale
QA Contact: Asha Akkiangady
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1399979
TreeView+ depends on / blocked
 
Reported: 2016-02-01 16:32 UTC by Matthew Harmsen
Modified: 2017-08-01 22:46 UTC (History)
10 users (show)

Fixed In Version: pki-core-10.4.1-3.el7
Doc Type: Enhancement
Doc Text:
Certificate System now supports externally authenticated users Previously, you had to create users and roles in Certificate System. With this enhancement, you can now configure Certificate System to admit users authenticated by an external identity provider. Additionally, you can use realm-specific authorization access control lists (ACLs). As a result, it is no longer necessary to create users in Certificate System.
Clone Of:
Environment:
Last Closed: 2017-08-01 22:46:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2110 normal SHIPPED_LIVE pki-core bug fix and enhancement update 2017-08-01 19:36:59 UTC

Description Matthew Harmsen 2016-02-01 16:32:41 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/pki/ticket/1359

When used within the FreeIPA project dogtag should allow authenticating using GSSAPI. Users can be mapped to the FreeIPA directory suffix in this case.
Using GSSAPI would allow the IPA framework to foully delegate to dogtag's ACLs some operations requested by users.

Comment 1 Matthew Harmsen 2016-04-21 16:03:12 UTC
Per CS Bug/Ticket Triage held 04/19/2016:  RHEL 7.4

Confirmed with Fraser.

Comment 2 Ann Marie Rubin 2017-01-06 20:07:37 UTC
RHCS 9.2 PRD item 1.3 is medium priority.

Comment 5 Matthew Harmsen 2017-04-19 15:40:50 UTC
Changes have been pushed to master; moving bug to POST for inclusion in RHEL 7.4 (beta).

Comment 8 Fraser Tweedale 2017-05-31 08:59:20 UTC
This ticket is closely related to
https://bugzilla.redhat.com/show_bug.cgi?id=1388622.

This is not a feature we are actively using in IPA or elsewhere
at the moment, but we wanted to land the changes as early as possible.
IPA will make use of them in a future release.

Therefore, it is quite involved to test.  I recommend moving
on to other bugs, while I work on a blog post explaining
these features and provides examples that can be used to
verify the new functionality.

I'd also recommend the same QE contact verify both bugs.

Comment 9 Asha Akkiangady 2017-06-23 19:33:17 UTC
This feature is not tested. RHCS subsystems installation and functional tests looks good.

Marking it verified sanity only.

Comment 12 errata-xmlrpc 2017-08-01 22:46:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2110


Note You need to log in before you can comment on or make changes to this bug.