Bug 1303694 - bad string in error message when testing external provider without permissions
bad string in error message when testing external provider without permissions
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.3
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Boriso
movciari
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 11:54 EST by movciari
Modified: 2016-07-27 06:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 06:07:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57245 master NEW webadmin: fix error message when unautherized access providers 2016-05-09 06:25 EDT

  None (edit)
Description movciari 2016-02-01 11:54:18 EST
Description of problem:
When testing the provider's liveliness while the user doesn't have the right permissions for that, the operation failed as expected but the error message has redundant underscore at the end:
"User is not authorized to perform this action_" instead of "User is not authorized to perform this action"

Version-Release number of selected component (if applicable):
3.6.3-0.1.el6

How reproducible:
always

Steps to Reproduce:
1. Have a provider (Foreman in my case)
2. Access RHEVM with a cluster admin user 
3. Test the provider
Comment 1 Eli Mesika 2016-02-02 05:33:35 EST
Can you please attach a screenshot showing that ?

thanks
Comment 3 Sandro Bonazzola 2016-05-02 06:08:31 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Gil Klein 2016-07-27 06:07:23 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.