Bug 1303729 - Unable to zero-out MAC address for mlx4_core device
Unable to zero-out MAC address for mlx4_core device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 14:11 EST by Jay Turner
Modified: 2016-05-27 09:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-27 09:34:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2016-02-01 14:11:01 EST
Description of problem:
Issue is as described in this thread, https://www.redhat.com/archives/libvir-list/2015-December/msg00683.html

Basically at de-allocation of a Mellanox VF, the MAC address should be zeroed-out.  Instead there seems to be an issue with the mlx4_core driver which is preventing that action, and the net result is the assigned MAC address stayed tied to the VF, but returned to the pool, significantly raising the risk of a MAC address collision.  We have worked around this issue for now by pre-allocating MAC addresses to all VFs, but that is not scalable for our purposes.  It would be far better to allow oVirt/libvirt to handle MAC address management on the VFs.

Version-Release number of selected component (if applicable):
$ modinfo mlx4_core
filename:       /lib/modules/4.3.4-300.fc23.x86_64/kernel/drivers/net/ethernet/mellanox/mlx4/mlx4_core.ko.xz
version:        2.2-1


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Chandrasekar Kannan 2016-02-01 15:24:23 EST
also see - https://bugzilla.redhat.com/show_bug.cgi?id=1302166
Comment 2 Josh Boyer 2016-02-03 05:08:41 EST
Did anyone ever address this with the mellanox developers upstream?  It seems Moshe was involved in the discussion on the libvirt list, but I've not seen any follow up on the netdev list that I can find.

If the behavior of the mlx4 driver needs to change (among other drivers) to zero out the MAC on deallocation, then it needs to be discussed and changed upstream.
Comment 3 Jay Turner 2016-02-03 11:22:00 EST
I have raised the issue with Mellanox, who say their technical team is looking into the issue.  No clue if that will result in something positive, but some friendly pressure from Red Hat would be greatly appreciated.
Comment 4 Josh Boyer 2016-05-27 09:34:45 EDT
This was fixed in the 4.5.y rebase with commit 6e52242

Note You need to log in before you can comment on or make changes to this bug.