Bug 1303796 - Python cartridge doesn't stop deploy process when it failed to install packages (It is different from behavior of other cartridges)
Python cartridge doesn't stop deploy process when it failed to install packag...
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Deployments (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Vu Dinh
zhou ying
:
Depends On:
Blocks: 1314546
  Show dependency treegraph
 
Reported: 2016-02-01 20:21 EST by Kenjiro Nakayama
Modified: 2017-05-31 14:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1314546 (view as bug list)
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2016-02-01 20:21:14 EST
Description of problem:
---
- Python cartridge doesn't stop deploy process when it failed to install packages (It is different from the behavior of other packages)


Version-Release number of selected component (if applicable):
---
- OpenShift Online
- OpenShift Enterprise 2.x
- OpenShift origin-server


Steps to Reproduce:
---
1. Put *wrong* package down requirements.txt.

e.g: foo==1.1.1 (the package 'foo' doesn't exist)

  foo==1.1.1
  Django==1.7.4
  Pillow==2.6.1
  ...

2. Deploy test

  $ git commit -am "package test" && git push

3. Pacakge installation failed (output the pip installation failed error), but the deploy result is "success"


Actual results:
---
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://xxxxxxxxxxxxxx@djangofoo-kenjiro.rhcloud.com/~/git/djangofoo.git/
   9765ac3..9a4a2cf  master -> master


Expected results:
---
- The deploy process stopped due to the package installation failure


Additional info:
- Here is the proposal patch - https://github.com/openshift/origin-server/pull/6357
- However, it has been removed purposely before - https://github.com/openshift/origin-server/pull/3542
  So, it might cause another side effect.
Comment 1 Vu Dinh 2016-02-02 10:52:07 EST
Regarding the customer case attached, it's clear that the package pybing is not longer available and in fact, the Bing API version it currently uses will be deprecated soon. So, it will be broken in the near future if it's not getting updates for that matter. There is an alternative package "py-bing-search" that may work for the customer. I just want to put it here for the record in case the customer requires further assistant in the future.
Comment 2 Vu Dinh 2016-02-02 10:55:47 EST
Current PR in review for merge: https://github.com/openshift/origin-server/pull/6357
Comment 6 zhou ying 2016-02-16 01:13:02 EST
Hi Vu:
   Yes, I've covered with the Python cartridges 2.7 and 3.3.
Comment 7 Vu Dinh 2016-02-16 11:48:43 EST
Thank you for confirmation.
Comment 8 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.