Bug 1303816 - Errata incremental update content view not working with non-admin user
Errata incremental update content view not working with non-admin user
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.5
All Linux
medium Severity medium (vote)
: 6.2.3
: --
Assigned To: Brad Buckingham
jcallaha
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 00:16 EST by Kumudini Shirsale
Modified: 2016-10-26 08:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.81-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 08:25:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom role (36.89 KB, image/png)
2016-10-13 15:55 EDT, jcallaha
no flags Details
verification screenshot (96.64 KB, image/png)
2016-10-13 15:55 EDT, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 15918 None None None 2016-08-19 15:33 EDT

  None (edit)
Comment 6 Brad Buckingham 2016-07-31 13:04:21 EDT
Upstream Katello PR: https://github.com/Katello/katello/pull/6217

Note: the permissions needed to perform incremental update include:

- Organization => view_organizations

- Lifecycle Environment => view_lifecycle_environments, promote_or_remove_content_views_to_environments

- Content Views => view_content_views, publish_content_views, promote_or_remove_content_views

- Host => view_hosts, edit_hosts
Comment 9 jcallaha 2016-10-13 15:53:23 EDT
Verified in Satellite 6.2.3 Snap 3.

Setup a role with the permissions outlined in #6. See attached.
Created two content views, one without errata filters, one with.
Registered a host to the filtered content view.
Switched to testuser (with custom permissions role)
Applied errata to host, incrementally updating the filtered content view (see attached for verification)
Comment 10 jcallaha 2016-10-13 15:55 EDT
Created attachment 1210249 [details]
custom role
Comment 11 jcallaha 2016-10-13 15:55 EDT
Created attachment 1210250 [details]
verification screenshot
Comment 13 errata-xmlrpc 2016-10-26 08:25:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108

Note You need to log in before you can comment on or make changes to this bug.