Bug 1303820 - It hangs up when login openshift from git bash on windows
It hangs up when login openshift from git bash on windows
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Windows
medium Severity medium
: ---
: ---
Assigned To: Sally
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 01:09 EST by Yanping Zhang
Modified: 2017-05-31 14:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hang-login (129.00 KB, image/png)
2016-02-02 01:16 EST, Yanping Zhang
no flags Details
hang-again (213.89 KB, image/png)
2016-02-03 23:33 EST, Yanping Zhang
no flags Details
screenshot for git for windows install (60.88 KB, image/png)
2016-02-04 11:26 EST, Sally
no flags Details

  None (edit)
Description Yanping Zhang 2016-02-02 01:09:23 EST
Description of problem:
When login openshift from git bash on windows, after input password, it hangs there all the time.

Version-Release number of selected component (if applicable):
rhc 1.38.4.gem, rhc 1.38.5.gem, rhc 1.38.6.gem
git 2.7.0

How reproducible:
Always

Steps to Reproduce:
1.Login openshift from git bash on win10
$rhc setup --server=<serverIp>
2.
3.

Actual results:
1.After input password, it hangs there all the time. User can not login from git bash directly.

Expected results:
1.Should login successfully.

Additional info:
Could login from other bash, ex: Win cmd, ruby bash.
Comment 1 Yanping Zhang 2016-02-02 01:16 EST
Created attachment 1120329 [details]
hang-login
Comment 2 Sally 2016-02-02 14:18:31 EST
I can't reproduce this bug.  Can you provide more info?
mine:
Ruby version 1.9.3
Windows 10
git 2.7.0

I'm running in Git Bash:
gem install <name of gem>
rhc setup --server=openshift.redhat.com

rhc setup successfully completes.
Thanks
Comment 3 Yanping Zhang 2016-02-03 05:40:57 EST
Here is my system info, hope it helps:
Ruby version 2.1.7p400
Windows 10
git 2.7.0

I run in Git Bash:
gem install <rhc gem>
rhc setup --server=<my openshift server>  (the server env works)
It hangs after input password
Comment 4 Sally 2016-02-03 17:25:20 EST
@Yanping, I did some more testing with Ruby 2.1.7p400

'rhc setup' succeeds for me if run from Ruby Start Command Prompt rather than Git Bash.   

Or, I had to run 'export PATH=$PATH:/c/Ruby21/bin' in Git Bash and then 'rhc setup' succeeded for me in Git Bash.

Thanks for going back and forth on this, hopefully we'll get to the bottom of it soon.  

Can you try the above 2 and let me know how it goes, thanks.
Comment 5 Yanping Zhang 2016-02-03 23:33:05 EST
@Sally.
"rhc setup" succeeds if run it from Ruby Start Command Prompt and from Command Prompt of win10, and failed in Git Bash.
Even after I ran 'export PATH=$PATH:/c/Ruby21/bin' in Git Bash and then 'rhc setup' still failed in Git Bash.
Comment 6 Yanping Zhang 2016-02-03 23:33 EST
Created attachment 1121025 [details]
hang-again
Comment 7 Sally 2016-02-04 11:26 EST
Created attachment 1121138 [details]
screenshot for git for windows install

screenshot with git for Windows install option
Comment 8 Sally 2016-02-04 11:29:53 EST
@Yanping, see Comment 7, please re-install git for Windows with the Windows default console window option rather than MinTTy.  Works for me!

Can you confirm that 'rhc setup' succeeds when installed with this option?  
Thanks!

I'll get documentation added for this.  When docs were created this option did not exist, see video here: https://developers.openshift.com/en/getting-started-windows.html#_video_walkthrough_for_installing_client_tools_rhc_on_windows
Comment 9 Yanping Zhang 2016-02-15 02:32:01 EST
Reinstall git for Windows with the Windows default console window option rather than MinTTy. Then rhc setup in git bash succeeds.
Comment 10 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.