Bug 1303833 - [RFE] Quota enforcement for Number of templates does not work
[RFE] Quota enforcement for Number of templates does not work
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: cfme-future
Assigned To: John Hardy
Aziza Karol
tenant_cfme:provision:quota
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 02:45 EST by Aziza Karol
Modified: 2017-08-28 10:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 10:50:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2016-02-02 02:45:42 EST
Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.2.20160121120249_395c086


How reproducible:
100%

Steps to Reproduce:
1.Navigate to configure->Access control->tenants
2.For Tenant " My Company " enforce template quota and set it to some value.
3.Navigate to Infrastructure -> Virtual machines -> Templates -> select VM template from list -> Lifecycle -> Clone selected template.
 or 
you can also select a VM and publish a VM to a template.


Actual results:
template gets created.

Expected results:
Quota exceeded message should be displayed

Additional info:
Comment 2 Shveta 2016-02-02 19:12:35 EST
Assigning to add test case
Comment 3 William Fitzgerald 2016-02-08 10:13:43 EST
Template Quota checking is currently not supported.  Changing to enhancement request.
Comment 5 Chris Pelland 2017-08-28 10:50:54 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.