Bug 130385 - autopoint depends on older version of gettext
Summary: autopoint depends on older version of gettext
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-19 20:25 UTC by Richard Li
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 17:54:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Li 2004-08-19 20:25:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
[richardl@conundrum monotone]$ autoreconf --install
/usr/bin/autopoint: line 341: /usr/share/gettext/archive.tar.gz: No
such file or directory
cvs checkout: cannot find module `archive' - ignored
find: archive: No such file or directory
find: archive: No such file or directory
autopoint: *** infrastructure files for version 0.12.1 not found; this
is autopoint from GNU gettext-tools 0.14.1
autopoint: *** Stop.
autoreconf: autopoint failed with exit status: 1

I have gettext-0.14.1-7 installed. In order to avoid the above
problem, I need to downgrade to gettext-0.12.


Version-Release number of selected component (if applicable):
autoconf-2.59-3

How reproducible:
Always

Steps to Reproduce:
1. Run autoreconf --install.
2. Observe failure.
    

Additional info:

Comment 1 Daniel Reed 2004-08-20 03:20:59 UTC
autopoint is part of the gettext package. It looks like there is some
mismatch in our gettext package.

Comment 2 Leon Ho 2004-09-10 07:20:26 UTC
Richard, would you able to check if your configure.ac has this line?
AM_GNU_GETTEXT_VERSION(x.yy.zz)

Comment 3 Richard Li 2004-09-10 11:58:26 UTC
Yup:

[richardl@conundrum monotone]$ cat configure.ac | grep AM_GNU_GETTEXT
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION(0.12.1)

Comment 4 Leon Ho 2004-09-13 23:54:44 UTC
That means it requires 0.12.1 as gettext version. Please try to change
it to reflect to the current version of gettext. Thanks.

Comment 5 Leon Ho 2004-10-01 17:54:43 UTC
I hope my comments help on the situation. Please feel free to reopen
if it does not help. Thanks!


Note You need to log in before you can comment on or make changes to this bug.